Bug 11937 - Quirksmode: Fixed > Overflow > Relative objects get hidden when scrolling
: Quirksmode: Fixed > Overflow > Relative objects get hidden when scrolling
Status: RESOLVED DUPLICATE of bug 9659
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 420+
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
http://www.quirksmode.org/bugreports/...
: HasReduction
Depends on:
Blocks: 9610
  Show dependency treegraph
 
Reported: 2006-12-22 19:39 PST by David Kilzer (:ddkilzer)
Modified: 2006-12-23 05:31 PST (History)
1 user (show)

See Also:


Attachments
Test page (4.04 KB, text/html)
2006-12-22 19:46 PST, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2006-12-22 19:39:48 PST
In Safari, when you have a object with a relative position, inside an object with overflow hidden, inside a fixed object, the relatively positioned object gets clipped when you scroll the page.

Reported on 17 July 2006.

Test page: http://eeoh.com.au/bugTesting/safari_fixed_overflow_relative_scroll_bug.html

Tested on locally-built debug build of WebKit r18399 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8N1037).
Comment 1 David Kilzer (:ddkilzer) 2006-12-22 19:46:16 PST
Created attachment 11976 [details]
Test page
Comment 2 mitz@webkit.org 2006-12-23 00:52:56 PST

*** This bug has been marked as a duplicate of 9659 ***