Bug 96366 - [WK2][WTR] WebKitTestRunner needs testRunner.callShouldCloseOnWebView
Summary: [WK2][WTR] WebKitTestRunner needs testRunner.callShouldCloseOnWebView
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Sudarsana Nagineni (babu)
URL:
Keywords:
: 96386 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-11 02:21 PDT by Sudarsana Nagineni (babu)
Modified: 2012-09-13 12:25 PDT (History)
3 users (show)

See Also:


Attachments
Patch (6.23 KB, patch)
2012-09-11 07:36 PDT, Sudarsana Nagineni (babu)
no flags Details | Formatted Diff | Diff
Patch (6.08 KB, patch)
2012-09-12 01:44 PDT, Sudarsana Nagineni (babu)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sudarsana Nagineni (babu) 2012-09-11 02:21:29 PDT
WebKitTestRunner needs testRunner.callShouldCloseOnWebView in order to unskip fast/events/onbeforeunload-focused-iframe.html
Comment 1 Mikhail Pozdnyakov 2012-09-11 07:31:31 PDT
*** Bug 96386 has been marked as a duplicate of this bug. ***
Comment 2 Sudarsana Nagineni (babu) 2012-09-11 07:36:11 PDT
Created attachment 163360 [details]
Patch
Comment 3 Chris Dumez 2012-09-11 07:50:08 PDT
Comment on attachment 163360 [details]
Patch

LGTM.
Comment 4 Kenneth Rohde Christiansen 2012-09-11 09:07:38 PDT
Comment on attachment 163360 [details]
Patch

I am not sure about the naming, can you pass this by Anders Carlsson?
Comment 5 Sudarsana Nagineni (babu) 2012-09-11 09:19:03 PDT
(In reply to comment #4)
> (From update of attachment 163360 [details])
> I am not sure about the naming, can you pass this by Anders Carlsson?

Sure. I'll ping Anders about this.
Comment 6 Alexey Proskuryakov 2012-09-11 13:23:05 PDT
Comment on attachment 163360 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=163360&action=review

> Source/WebKit2/WebProcess/InjectedBundle/API/c/WKBundleFrame.h:80
> +WK_EXPORT bool WKBundleFrameCallShouldCloseOnWebView(WKBundleFrameRef frame);

It's surprising to see this as API.
Comment 7 Sudarsana Nagineni (babu) 2012-09-12 01:44:06 PDT
Created attachment 163545 [details]
Patch

I moved this method to private now. Thanks for notifying, Alexey. The name is still same as it is in the test case.
Comment 8 Anders Carlsson 2012-09-13 12:15:47 PDT
Comment on attachment 163545 [details]
Patch

Looks good!
Comment 9 WebKit Review Bot 2012-09-13 12:25:49 PDT
Comment on attachment 163545 [details]
Patch

Clearing flags on attachment: 163545

Committed r128491: <http://trac.webkit.org/changeset/128491>
Comment 10 WebKit Review Bot 2012-09-13 12:25:53 PDT
All reviewed patches have been landed.  Closing bug.