RESOLVED FIXED 95912
IndexedDB: open-in-upgradeneeded layout test
https://bugs.webkit.org/show_bug.cgi?id=95912
Summary IndexedDB: open-in-upgradeneeded layout test
David Grogan
Reported 2012-09-05 16:52:50 PDT
IndexedDB: open-in-upgradeneeded layout test
Attachments
Patch (5.97 KB, patch)
2012-09-05 16:53 PDT, David Grogan
no flags
Patch (5.83 KB, patch)
2012-09-20 17:50 PDT, David Grogan
no flags
Patch (5.83 KB, patch)
2012-10-08 18:23 PDT, David Grogan
no flags
Patch (5.94 KB, patch)
2012-10-08 18:26 PDT, David Grogan
no flags
David Grogan
Comment 1 2012-09-05 16:53:27 PDT
David Grogan
Comment 2 2012-09-05 17:05:29 PDT
This should wait until after 90411 lands. This currently behaves differently in DRT and content_shell, though I'm not sure which is more correct. Suppose we call the result of this test in DRT "A" and the result from content_shell "B". "B" is included in this patch. It's also what firefox produces. If the code from 90411 is patched in, the result of this test in DRT is now "B". But then the result from content_shell ("C") is different from either "A" or "B". "C" is definitely wrong. So I'll wait until 90411 lands and sort this out after.
WebKit Review Bot
Comment 3 2012-09-07 12:40:44 PDT
Comment on attachment 162370 [details] Patch Attachment 162370 [details] did not pass chromium-ews (chromium-xvfb): Output: http://queues.webkit.org/results/13785566 New failing tests: storage/indexeddb/intversion-open-in-upgradeneeded.html
Joshua Bell
Comment 4 2012-09-19 16:58:07 PDT
I just tried this patch again, and it passes in DRT and content_shell's output matches. Did we simplify 90411 enough to eliminate the "B" => "C" change?
David Grogan
Comment 5 2012-09-20 17:50:36 PDT
David Grogan
Comment 6 2012-09-20 17:51:45 PDT
Yeah, seems to work. Can you look it over for an LGTM?
Joshua Bell
Comment 7 2012-09-21 12:59:39 PDT
Comment on attachment 165022 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=165022&action=review lgtm > LayoutTests/storage/indexeddb/resources/intversion-open-in-upgradeneeded.js:36 > + transaction.oncomplete = function() { Just as a style thing, if this was written as: transaction.oncomplete = function transactionOnComplete(evt) { ... then you could use preamble(evt); and get the name printed out while still (IMHO) keeping the readability benefits of a function expression. (I haven't done that anywhere myself, was just pondering it while reading this patch.) > LayoutTests/storage/indexeddb/resources/intversion-open-in-upgradeneeded.js:55 > + evalAndLog("transaction = db.transaction('os')"); Is this just to confirm that the connection is still open? Maybe a debug() line explaining it would help.
Joshua Bell
Comment 8 2012-10-02 13:38:18 PDT
Is this waiting on anything?
David Grogan
Comment 9 2012-10-08 18:23:05 PDT
David Grogan
Comment 10 2012-10-08 18:26:33 PDT
David Grogan
Comment 11 2012-10-08 18:27:54 PDT
Tony, could you review this test?
WebKit Review Bot
Comment 12 2012-10-09 12:18:27 PDT
Comment on attachment 167665 [details] Patch Clearing flags on attachment: 167665 Committed r130791: <http://trac.webkit.org/changeset/130791>
WebKit Review Bot
Comment 13 2012-10-09 12:18:32 PDT
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.