Bug 94169 - (r125629): Newly added test css3/filters/custom/filter-fallback-to-software.html failing on mac
Summary: (r125629): Newly added test css3/filters/custom/filter-fallback-to-software.h...
Status: RESOLVED DUPLICATE of bug 94120
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2012-08-15 18:49 PDT by Kiran Muppala
Modified: 2012-08-16 13:55 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.48 KB, patch)
2012-08-15 19:42 PDT, Kiran Muppala
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kiran Muppala 2012-08-15 18:49:35 PDT
The layout test css3/filters/custom/filter-fallback-to-software.html, added by https://bugs.webkit.org/show_bug.cgi?id=93900
in r125629 is failing on mac.

http://build.webkit.org/results/Apple%20Lion%20Debug%20WK1%20(Tests)/r125632%20(1885)/css3/filters/custom/filter-fallback-to-software-diff.png
Comment 1 Kiran Muppala 2012-08-15 19:42:31 PDT
Created attachment 158694 [details]
Patch
Comment 2 Kiran Muppala 2012-08-15 19:47:37 PDT
Attached patch to add failing test to test expectations.
Comment 3 Alexandru Chiculita 2012-08-15 19:57:52 PDT
Thanks for adding the test expectations! I have another bug to investigate the issue. It seems that there is another change that introduced it and I've added more comments there.
https://bugs.webkit.org/show_bug.cgi?id=94120
Comment 4 Kiran Muppala 2012-08-15 20:16:03 PDT
(In reply to comment #3)
> Thanks for adding the test expectations! I have another bug to investigate the issue. It seems that there is another change that introduced it and I've added more comments there.
> https://bugs.webkit.org/show_bug.cgi?id=94120

I actually happened to add test expectations for the other test in that bug, namely css3/filters/custom/invalid-custom-filter-shader.html, as well (https://bugs.webkit.org/show_bug.cgi?id=94067).  Thanks for filing it.  Sounds like, it will address both the tests.
Comment 5 WebKit Review Bot 2012-08-15 20:56:54 PDT
Comment on attachment 158694 [details]
Patch

Clearing flags on attachment: 158694

Committed r125742: <http://trac.webkit.org/changeset/125742>
Comment 6 WebKit Review Bot 2012-08-15 20:56:58 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Kiran Muppala 2012-08-15 21:22:36 PDT
Re-opening because the previous patch only marks the test as an expected failure, but does not fix the underlying issue.
Comment 8 Alexandru Chiculita 2012-08-16 13:55:11 PDT

*** This bug has been marked as a duplicate of bug 94120 ***