Bug 93847 - [Qt] Very strange incremental build bug
Summary: [Qt] Very strange incremental build bug
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Blocker
Assignee: Tor Arne Vestbø
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2012-08-13 07:38 PDT by Csaba Osztrogonác
Modified: 2012-09-05 06:11 PDT (History)
6 users (show)

See Also:


Attachments
build log from the bot (43.89 KB, text/plain)
2012-08-13 07:38 PDT, Csaba Osztrogonác
no flags Details
build log from the bot - same revision, second build, success (108.64 KB, text/plain)
2012-08-13 07:49 PDT, Csaba Osztrogonác
no flags Details
diff between WebKitBuild directories (166.91 KB, patch)
2012-08-13 08:00 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (2.94 KB, patch)
2012-09-05 05:48 PDT, Tor Arne Vestbø
ossy: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2012-08-13 07:38:05 PDT
Created attachment 157995 [details]
build log from the bot

There are an incremental build bug on the Qt bots intermittently.
(~ once a week) Unfortunately it's impossible to reproduce it.

But now I have a build log for it and I saved the full 
WebKitBuild directory to help to find the root of the bug.
Comment 1 Csaba Osztrogonác 2012-08-13 07:49:33 PDT
Created attachment 157999 [details]
build log from the bot - same revision, second build, success
Comment 2 Csaba Osztrogonác 2012-08-13 08:00:17 PDT
Created attachment 158002 [details]
diff between WebKitBuild directories

 left side (-): broken build
right side (+): second and working build
Comment 5 Csaba Osztrogonác 2012-08-22 09:12:33 PDT
Do we need more build logs from other bots?
Comment 7 Csaba Osztrogonác 2012-08-27 23:57:04 PDT
One more different strange build fail: http://build.webkit.sed.hu/builders/x86-32%20Linux%20Qt%20Release%20NRWT/builds/18644/steps/compile-webkit/logs/stdio
Comment 9 Csaba Osztrogonác 2012-08-31 06:34:57 PDT
One more fail, now on the EWS bot:
- bug: https://bugs.webkit.org/show_bug.cgi?id=95382#c5
- build log: http://queues.webkit.org/results/13689448

It would be great to fix this crazy bug as soon as possible ...
Or else nobody will trust in Qt buildbots and EWS bot. :-(
Comment 10 Simon Hausmann 2012-08-31 06:50:06 PDT
The "make[4]: *** No targets.  Stop." makes me wonder if this is perhaps the result of a corrupted make file due to two qmake instances writing the same file. That would also explain why the likely-hood of this is somewhat related to the number of parallel jobs.
Comment 11 Csaba Osztrogonác 2012-08-31 07:14:08 PDT
Maybe it is related to https://trac.webkit.org/changeset/121966
Comment 13 Tor Arne Vestbø 2012-09-04 10:10:19 PDT
Taking
Comment 14 Tor Arne Vestbø 2012-09-05 05:48:33 PDT
Created attachment 162231 [details]
Patch
Comment 15 Csaba Osztrogonác 2012-09-05 05:53:34 PDT
Comment on attachment 162231 [details]
Patch

r=me, thanks for the fix.
Comment 16 Tor Arne Vestbø 2012-09-05 06:11:31 PDT
Committed r127583: <http://trac.webkit.org/changeset/127583>