Bug 93109 - Remove all usages of M_PI from WebCore
Summary: Remove all usages of M_PI from WebCore
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Patrick R. Gansterer
URL:
Keywords:
: 52197 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-03 07:05 PDT by Patrick R. Gansterer
Modified: 2013-10-09 15:13 PDT (History)
5 users (show)

See Also:


Attachments
Patch (7.68 KB, patch)
2012-08-03 07:08 PDT, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff
Patch (8.15 KB, patch)
2012-09-18 22:57 PDT, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff
Patch (8.15 KB, patch)
2012-09-19 05:16 PDT, Patrick R. Gansterer
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick R. Gansterer 2012-08-03 07:05:11 PDT
Remove all usages of M_PI from WebCore
Comment 1 Patrick R. Gansterer 2012-08-03 07:08:26 PDT
Created attachment 156363 [details]
Patch
Comment 2 Build Bot 2012-08-03 10:50:17 PDT
Comment on attachment 156363 [details]
Patch

Attachment 156363 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/13422867
Comment 3 Eric Seidel (no email) 2012-08-07 15:31:02 PDT
Comment on attachment 156363 [details]
Patch

Why?  Looks like Mac didn't like this chnage, but otherwise I'm OK with it if the EWSes are.
Comment 4 Patrick R. Gansterer 2012-09-18 22:57:38 PDT
Created attachment 164666 [details]
Patch
Comment 5 Build Bot 2012-09-18 23:05:33 PDT
Comment on attachment 164666 [details]
Patch

Attachment 164666 [details] did not pass mac-ews (mac):
Output: http://queues.webkit.org/results/13900415
Comment 6 Patrick R. Gansterer 2012-09-19 05:16:56 PDT
Created attachment 164721 [details]
Patch
Comment 7 Dirk Schulze 2012-09-19 07:38:12 PDT
Comment on attachment 164721 [details]
Patch

LGTM. r=me
Comment 8 WebKit Review Bot 2012-09-19 07:42:29 PDT
Comment on attachment 164721 [details]
Patch

Clearing flags on attachment: 164721

Committed r129005: <http://trac.webkit.org/changeset/129005>
Comment 9 WebKit Review Bot 2012-09-19 07:42:33 PDT
All reviewed patches have been landed.  Closing bug.
Comment 10 Alberto Garcia 2013-10-09 15:13:08 PDT
*** Bug 52197 has been marked as a duplicate of this bug. ***