Bug 92322 - flex items not honoring box-sizing: border-box in the main axis
Summary: flex items not honoring box-sizing: border-box in the main axis
Status: RESOLVED DUPLICATE of bug 70771
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-25 17:16 PDT by Scott Miles
Modified: 2012-07-25 17:23 PDT (History)
4 users (show)

See Also:


Attachments
Test case showing various flex items and unexpected sizes (2.50 KB, text/html)
2012-07-25 17:16 PDT, Scott Miles
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Miles 2012-07-25 17:16:21 PDT
Created attachment 154499 [details]
Test case showing various flex items and unexpected sizes

Column-flow flex items seem to ignore border-box directive for width (and for height in row-flow).
Comment 1 Tony Chang 2012-07-25 17:23:09 PDT
Yeah, we don't work with padding-box either.

Here are the existing bugs filed against flex box: https://bugs.webkit.org/showdependencytree.cgi?id=62048&hide_resolved=1

*** This bug has been marked as a duplicate of bug 70771 ***