Bug 70771 - need tests to ensure flexboxes play nicely with box-sizing
: need tests to ensure flexboxes play nicely with box-sizing
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Ojan Vafai
:
Depends on:
Blocks: 62048
  Show dependency treegraph
 
Reported: 2011-10-24 16:09 PDT by Ojan Vafai
Modified: 2012-08-06 12:17 PDT (History)
5 users (show)

See Also:


Attachments
Patch (8.96 KB, patch)
2012-07-31 18:29 PDT, Ojan Vafai
tony: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ojan Vafai 2011-10-24 16:09:18 PDT
Summary: need tests to ensure flexboxes play nicely with box-sizing
Comment 1 Tony Chang 2012-05-15 16:05:46 PDT
It was recently clarified that the flex-basis (aka preferred size) applies to the box-size.  I.e., if you are using border-box sizing, then the flex-basis is the length of the border-box.
Comment 2 Tony Chang 2012-07-25 17:23:09 PDT
*** Bug 92322 has been marked as a duplicate of this bug. ***
Comment 3 Ojan Vafai 2012-07-31 18:29:48 PDT
Created attachment 155699 [details]
Patch
Comment 4 Tony Chang 2012-08-05 18:02:41 PDT
Comment on attachment 155699 [details]
Patch

You're right, that was simple.
Comment 5 Ojan Vafai 2012-08-06 12:17:29 PDT
Committed r124793: <http://trac.webkit.org/changeset/124793>