Bug 9184 - Reproducible hang: document.location = "#anchor" causes page not to load
Summary: Reproducible hang: document.location = "#anchor" causes page not to load
Status: RESOLVED DUPLICATE of bug 6309
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.briandilg.com/imaging/inde...
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-31 06:14 PDT by Sveinbjörn J. Tryggvason
Modified: 2006-06-02 09:57 PDT (History)
3 users (show)

See Also:


Attachments
a simple html file with document.location = "#anchor" included -> doesn't work (1.01 KB, text/html)
2006-05-31 06:16 PDT, Sveinbjörn J. Tryggvason
no flags Details
the same html file as befor without the javascript -> works (1001 bytes, text/html)
2006-05-31 06:16 PDT, Sveinbjörn J. Tryggvason
no flags Details
Moved script to bottom of page (after anchor) (1.01 KB, text/html)
2006-05-31 06:42 PDT, David Kilzer (:ddkilzer)
no flags Details
testcase (136 bytes, text/html)
2006-06-01 04:06 PDT, Joost de Valk (AlthA)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sveinbjörn J. Tryggvason 2006-05-31 06:14:53 PDT
This pages begins to load - I get the title of the page in the top of the window but then just white. At that point I can't look at the source of the page.
Comment 1 Sveinbjörn J. Tryggvason 2006-05-31 06:16:07 PDT
Created attachment 8618 [details]
a simple html file with document.location = "#anchor" included -> doesn't work
Comment 2 Sveinbjörn J. Tryggvason 2006-05-31 06:16:38 PDT
Created attachment 8619 [details]
the same html file as befor without the javascript -> works
Comment 3 Sveinbjörn J. Tryggvason 2006-05-31 06:17:34 PDT
I'm very new to this bugzilla/bug-reporting thing.
Comment 4 David Kilzer (:ddkilzer) 2006-05-31 06:28:41 PDT
Confirming bug.  This is probably NOT a duplicate of Bug 6309 or Bug 8522.

This looks like it may be a recursion loop and/or infinite loop as the URL is only requested once from the server per Ethereal.

The failing test works fine in Firefox 1.5.0.3.

It would be interesting to find out if updating document.location.hash has the same effect or not.
Comment 5 David Kilzer (:ddkilzer) 2006-05-31 06:31:16 PDT
(In reply to comment #4)
> Confirming bug.

This occurs on Safari 2.0.3 (417.9.3) on Mac OS X 10.4.6 (8I127/PowerPC) as well as with a locally-built WebKit r14643.
Comment 6 Joost de Valk (AlthA) 2006-05-31 06:31:59 PDT
I'll look into this one tonight, i think i've seen rumors on the web that updating document.location.hash has the same result. That would probably be easy to test, for instance by moving the javascript in the first testcase to the bottom of the html file. Perhaps you could try that ddkilzer?
Comment 7 David Kilzer (:ddkilzer) 2006-05-31 06:42:48 PDT
Created attachment 8623 [details]
Moved script to bottom of page (after anchor)

The timer still spins endlessly after the page loads (if the script is moved to the bottom after the anchor).  The only difference is that you can now see the content.  Tested in WebKit r14643.  Time to go to work.  :(
Comment 8 Joost de Valk (AlthA) 2006-06-01 04:06:29 PDT
Created attachment 8637 [details]
testcase
Comment 9 Joost de Valk (AlthA) 2006-06-01 04:07:36 PDT
This turns out to be more of a problem then i thought it was, as a simple javascript:document.location.hash='test' causes a hang.
Comment 10 David Kilzer (:ddkilzer) 2006-06-02 09:57:52 PDT
This was fixed by the patch for Bug 6309, thus marking it as a duplicate.


*** This bug has been marked as a duplicate of 6309 ***