Bug 8522 - Back/forward navigation for fragment navigations does not update location object
Summary: Back/forward navigation for fragment navigations does not update location object
Status: RESOLVED DUPLICATE of bug 6309
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-21 13:12 PDT by Maciej Stachowiak
Modified: 2006-06-01 17:38 PDT (History)
2 users (show)

See Also:


Attachments
test case that demonstrates the problem (1.44 KB, text/html)
2006-04-21 13:18 PDT, Maciej Stachowiak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2006-04-21 13:12:11 PDT
If you navigate to a new fragment ID (#foo) and then go back, the location object doesn't properly reflect the previous location via location.href or location.hash. See attached test case.
Comment 1 Maciej Stachowiak 2006-04-21 13:18:12 PDT
Created attachment 7884 [details]
test case that demonstrates the problem
Comment 2 David Kilzer (:ddkilzer) 2006-05-27 04:23:30 PDT
I'm pretty sure this bug is a duplicate of Bug 6309.  If you read through that bug's comments, you'll see that the only issue left is the one described here.
Comment 3 David Kilzer (:ddkilzer) 2006-06-01 17:38:34 PDT
This bug was fixed when Bug 6309 was fixed, so marking it as a duplicate.


*** This bug has been marked as a duplicate of 6309 ***