Bug 91442 - nrwt: move the bulk of the "expected" output to printing.py
Summary: nrwt: move the bulk of the "expected" output to printing.py
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dirk Pranke
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-16 16:33 PDT by Dirk Pranke
Modified: 2012-07-17 16:08 PDT (History)
4 users (show)

See Also:


Attachments
Patch (9.89 KB, patch)
2012-07-16 16:34 PDT, Dirk Pranke
ojan: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Pranke 2012-07-16 16:33:26 PDT
nrwt: move the bulk of the "expected" output to printing.py
Comment 1 Dirk Pranke 2012-07-16 16:34:42 PDT
Created attachment 152640 [details]
Patch
Comment 2 Ojan Vafai 2012-07-17 13:29:47 PDT
Comment on attachment 152640 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=152640&action=review

> Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:421
> +        self._printer._print_expected(tests_run_msg)

Calling a private method here. This should probably be print_expected and print_expected below should be something like...print_expected_details or something.
Comment 3 Dirk Pranke 2012-07-17 13:35:07 PDT
(In reply to comment #2)
> (From update of attachment 152640 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=152640&action=review
> 
> > Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:421
> > +        self._printer._print_expected(tests_run_msg)
> 
> Calling a private method here. This should probably be print_expected and print_expected below should be something like...print_expected_details or something.

That gets fixed in https://bugs.webkit.org/show_bug.cgi?id=91447 , where these messages turn into _log.debug(). Is it okay to leave this as-is for the moment, or should I merge the other patch into this one, or would you prefer I rename the methods as you suggest?
Comment 4 Ojan Vafai 2012-07-17 13:45:19 PDT
Comment on attachment 152640 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=152640&action=review

>>> Tools/Scripts/webkitpy/layout_tests/controllers/manager.py:421
>>> +        self._printer._print_expected(tests_run_msg)
>> 
>> Calling a private method here. This should probably be print_expected and print_expected below should be something like...print_expected_details or something.
> 
> That gets fixed in https://bugs.webkit.org/show_bug.cgi?id=91447 , where these messages turn into _log.debug(). Is it okay to leave this as-is for the moment, or should I merge the other patch into this one, or would you prefer I rename the methods as you suggest?

I see. Given that I've already r+'ed the other patch, I think it's fine. :)
Comment 5 Dirk Pranke 2012-07-17 16:08:24 PDT
Committed r122887: <http://trac.webkit.org/changeset/122887>