Bug 90687 - [Qt] REGRESSION: 5 tests started to fail with newer Qt5
Summary: [Qt] REGRESSION: 5 tests started to fail with newer Qt5
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Marcelo Lira
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks: 79666
  Show dependency treegraph
 
Reported: 2012-07-06 07:09 PDT by Csaba Osztrogonác
Modified: 2012-10-10 10:52 PDT (History)
5 users (show)

See Also:


Attachments
Patch (7.09 KB, patch)
2012-09-20 14:24 PDT, Marcelo Lira
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2012-07-06 07:09:48 PDT
The following tests started to fail after updating Qt5 for WebKit trunk:
(http://lists.webkit.org/pipermail/webkit-qt/2012-July/002961.html)
http/tests/cookies/double-quoted-value-with-semi-colon.html
http/tests/xmlhttprequest/methods.html
http/tests/xmlhttprequest/workers/methods-async.html
http/tests/xmlhttprequest/workers/methods.html
http/tests/xmlhttprequest/workers/shared-worker-methods-async.html

--- /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/cookies/double-quoted-value-with-semi-colon-expected.txt
+++ /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/cookies/double-quoted-value-with-semi-colon-actual.txt
@@ -4,7 +4,7 @@
 
 
 Check that setting a cookie with a semi-colon in a duoble-quoted value works
-PASS cookie is 'disorder="477beccb;richard"'.
+FAIL cookie was 'disorder="477beccb'. Expected 'disorder="477beccb;richard"'.
 PASS successfullyParsed is true
 
 TEST COMPLETE



--- /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/methods-expected.txt
+++ /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/methods-actual.txt
@@ -4,7 +4,7 @@
 GET(null): GET(null bytes), Content-Type: null
 GET("123"): GET(null bytes), Content-Type: null
 POST(""): POST(0 bytes), Content-Type: application/xml
-POST(null): POST(0 bytes), Content-Type: application/octet-stream
+POST(null): POST(0 bytes), Content-Type: application/x-www-form-urlencoded
 POST("123"): POST(3 bytes), Content-Type: application/xml
 PUT(""): PUT(0 bytes), Content-Type: application/xml
 PUT(null): PUT(0 bytes), Content-Type: null



--- /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/workers/methods-async-expected.txt
+++ /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/workers/methods-async-actual.txt
@@ -4,7 +4,7 @@
 GET(null): GET(null bytes), Content-Type: null
 GET("123"): GET(null bytes), Content-Type: null
 POST(""): POST(0 bytes), Content-Type: application/xml
-POST(null): POST(0 bytes), Content-Type: application/octet-stream
+POST(null): POST(0 bytes), Content-Type: application/x-www-form-urlencoded
 POST("123"): POST(3 bytes), Content-Type: application/xml
 PUT(""): PUT(0 bytes), Content-Type: application/xml
 PUT(null): PUT(0 bytes), Content-Type: null



--- /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/workers/methods-expected.txt
+++ /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/workers/methods-actual.txt
@@ -4,7 +4,7 @@
 GET(null): GET(null bytes), Content-Type: null
 GET("123"): GET(null bytes), Content-Type: null
 POST(""): POST(0 bytes), Content-Type: application/xml
-POST(null): POST(0 bytes), Content-Type: application/octet-stream
+POST(null): POST(0 bytes), Content-Type: application/x-www-form-urlencoded
 POST("123"): POST(3 bytes), Content-Type: application/xml
 PUT(""): PUT(0 bytes), Content-Type: application/xml
 PUT(null): PUT(0 bytes), Content-Type: null



--- /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/workers/shared-worker-methods-async-expected.txt
+++ /home/webkitbuildbot/slaves/release64bitWebKit2_EC2/buildslave/qt-linux-64-release-webkit2/build/layout-test-results/http/tests/xmlhttprequest/workers/shared-worker-methods-async-actual.txt
@@ -4,7 +4,7 @@
 GET(null): GET(null bytes), Content-Type: null
 GET("123"): GET(null bytes), Content-Type: null
 POST(""): POST(0 bytes), Content-Type: application/xml
-POST(null): POST(0 bytes), Content-Type: application/octet-stream
+POST(null): POST(0 bytes), Content-Type: application/x-www-form-urlencoded
 POST("123"): POST(3 bytes), Content-Type: application/xml
 PUT(""): PUT(0 bytes), Content-Type: application/xml
 PUT(null): PUT(0 bytes), Content-Type: null
Comment 1 Csaba Osztrogonác 2012-07-06 07:22:15 PDT
I skipped them by r121970.
Comment 2 Marcelo Lira 2012-09-20 14:24:01 PDT
Created attachment 164981 [details]
Patch
Comment 3 WebKit Review Bot 2012-09-21 09:26:22 PDT
Comment on attachment 164981 [details]
Patch

Clearing flags on attachment: 164981

Committed r129234: <http://trac.webkit.org/changeset/129234>
Comment 4 WebKit Review Bot 2012-09-21 09:26:25 PDT
All reviewed patches have been landed.  Closing bug.
Comment 5 Allan Sandfeld Jensen 2012-10-10 08:23:17 PDT
The new Qt5 specific results should have been put under platform/qt-5.0, not under platform/qt. We still support Qt-4.8 in test results.
Comment 6 Csaba Osztrogonác 2012-10-10 08:26:03 PDT
(In reply to comment #5)
> The new Qt5 specific results should have been put under platform/qt-5.0, not under platform/qt. We still support Qt-4.8 in test results.

Hmmm ... I thought we don't support Qt 4.8 on trunk anymore. Who 
knows if a test result is 4.8/5.0 specific or same on 4.8 and 5.0 ?
Comment 7 Allan Sandfeld Jensen 2012-10-10 08:35:01 PDT
(In reply to comment #6)
> (In reply to comment #5)
> > The new Qt5 specific results should have been put under platform/qt-5.0, not under platform/qt. We still support Qt-4.8 in test results.
> 
> Hmmm ... I thought we don't support Qt 4.8 on trunk anymore. Who 
> knows if a test result is 4.8/5.0 specific or same on 4.8 and 5.0 ?

In this case the commit message and bug specifically mentions it.
Comment 8 Marcelo Lira 2012-10-10 10:14:28 PDT
(In reply to comment #7)
> (In reply to comment #6)
> > (In reply to comment #5)
> > > The new Qt5 specific results should have been put under platform/qt-5.0, not under platform/qt. We still support Qt-4.8 in test results.
> > 
> > Hmmm ... I thought we don't support Qt 4.8 on trunk anymore. Who 
> > knows if a test result is 4.8/5.0 specific or same on 4.8 and 5.0 ?
> 
> In this case the commit message and bug specifically mentions it.

Sorry, my bad for mentioning Qt 4.8, since I had in mind that, as Ossy said, 4.8 was not supported anymore.
Comment 9 Allan Sandfeld Jensen 2012-10-10 10:33:34 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > (In reply to comment #5)
> > > > The new Qt5 specific results should have been put under platform/qt-5.0, not under platform/qt. We still support Qt-4.8 in test results.
> > > 
> > > Hmmm ... I thought we don't support Qt 4.8 on trunk anymore. Who 
> > > knows if a test result is 4.8/5.0 specific or same on 4.8 and 5.0 ?
> > 
> > In this case the commit message and bug specifically mentions it.
> 
> Sorry, my bad for mentioning Qt 4.8, since I had in mind that, as Ossy said, 4.8 was not supported anymore.

It isn't but we still share the same test-results (more or less). If we were to stop caring about the separation in trunk, we should rename the top Qt platform results from qt to qt-5.0, since the branching from qt to either qt-4.8 or qt-5.0 becomes meaningless.
Comment 10 Rafael Brandao 2012-10-10 10:52:35 PDT
I agree, but when we have more qt versions in trunk, then we will have to bring qt folder back.