Bug 90170 - [EFL] Add Gamepad support
: [EFL] Add Gamepad support
Status: RESOLVED FIXED
: WebKit
WebKit EFL
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2012-06-28 06:28 PST by
Modified: 2012-07-01 23:22 PST (History)


Attachments
Patch (19.64 KB, patch)
2012-06-29 07:08 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Patch (20.57 KB, patch)
2012-06-29 11:35 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff
Patch (20.17 KB, patch)
2012-06-29 11:39 PST, Christophe Dumez
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-06-28 06:28:54 PST
The EFL port does not currently support Gamepads. I'm planning to add support by using udev, via the EEZE library.
------- Comment #1 From 2012-06-28 10:55:30 PST -------
EEZE library does not currently support JOYSTICK devices so I wrote a patch for it: http://trac.enlightenment.org/e/ticket/1100
------- Comment #2 From 2012-06-29 07:08:59 PST -------
Created an attachment (id=150170) [details]
Patch
------- Comment #3 From 2012-06-29 10:01:02 PST -------
(From update of attachment 150170 [details])
Clearing flags for now.
------- Comment #4 From 2012-06-29 11:35:17 PST -------
Created an attachment (id=150225) [details]
Patch

Actually tested with a gamepad and fixed a few bugs.
------- Comment #5 From 2012-06-29 11:39:59 PST -------
Created an attachment (id=150229) [details]
Patch

Fix changelog entries.
------- Comment #6 From 2012-06-30 16:41:28 PST -------
(From update of attachment 150229 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=150229&action=review

> Source/cmake/FindEFL.cmake:7
> +  eina>=1.2.0

I bump efl libraries version on Bug 90333 because of supporting network information APIs. I wonder whether Bug 90333 can support this patch as well.
------- Comment #7 From 2012-07-01 19:10:32 PST -------
(From update of attachment 150229 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=150229&action=review

> Source/WebCore/platform/efl/GamepadsEfl.cpp:208
> +void GamepadsEfl::updateGamepadList(GamepadList* into)

into?
------- Comment #8 From 2012-07-01 19:59:24 PST -------
Christophe, if possible, I would like to land Bug 90333. So, could you let me know if Bug 90333 can support this patch as well?
------- Comment #9 From 2012-07-01 22:29:13 PST -------
(In reply to comment #7)
> (From update of attachment 150229 [details] [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=150229&action=review
> 
> > Source/WebCore/platform/efl/GamepadsEfl.cpp:208
> > +void GamepadsEfl::updateGamepadList(GamepadList* into)
> 
> into?

Yes, I copied the prototype from Gamepads.h in WebCore/platform:
void sampleGamepads(GamepadList* into);
------- Comment #10 From 2012-07-01 22:32:57 PST -------
*** Bug 90333 has been marked as a duplicate of this bug. ***
------- Comment #11 From 2012-07-01 23:22:31 PST -------
(From update of attachment 150229 [details])
Clearing flags on attachment: 150229

Committed r121657: <http://trac.webkit.org/changeset/121657>
------- Comment #12 From 2012-07-01 23:22:37 PST -------
All reviewed patches have been landed.  Closing bug.