Bug 89205 - REGRESSION (r120423): editing/spelling/grammar-edit-word.html failing on GTK Linux 64-bit Release
Summary: REGRESSION (r120423): editing/spelling/grammar-edit-word.html failing on GTK ...
Status: RESOLVED DUPLICATE of bug 89199
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: http://build.webkit.org/results/GTK%2...
Keywords: Gtk, LayoutTestFailure, MakingBotsRed, Regression
Depends on:
Blocks:
 
Reported: 2012-06-15 06:52 PDT by Zan Dobersek
Modified: 2012-10-08 13:50 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2012-06-15 06:52:38 PDT
editing/spelling/grammar-edit-word.html started failing on GTK Linux 64-bit Release after r120423.

http://trac.webkit.org/log/trunk?rev=1204234&stop_rev=120423&limit=3

http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release/r120422%20(25300)/results.html passed
http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release/r120424%20(25301)/results.html failed

Diff:
--- /home/slave/webkitgtk/gtk-linux-64-release/build/layout-test-results/editing/spelling/grammar-edit-word-expected.txt 
+++ /home/slave/webkitgtk/gtk-linux-64-release/build/layout-test-results/editing/spelling/grammar-edit-word-actual.txt 
@@ -4,7 +4,7 @@
 
 
 document.execCommand("InsertText", false, "You has the right.")
-PASS internals.hasGrammarMarker(document, 4, 3) is true
+FAIL internals.hasGrammarMarker(document, 4, 3) should be true. Was false.
 Delete the end of this sentence until it becomes "You ha".
 layoutTestController.execCommand("DeleteBackward")
 layoutTestController.execCommand("DeleteBackward")
Comment 1 Martin Robinson 2012-06-15 08:41:36 PDT
Hironori, your change seems to have caused this regression on GTK+.
Comment 2 Martin Robinson 2012-06-15 08:43:10 PDT

*** This bug has been marked as a duplicate of bug 89199 ***