Bug 88304 - [Qt][Win] Fix IDL dependency generation
: [Qt][Win] Fix IDL dependency generation
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: All All
: P1 Blocker
Assigned To: Csaba Osztrogonác
: Qt, QtTriaged
Depends on:
Blocks: 88300
  Show dependency treegraph
 
Reported: 2012-06-05 01:08 PDT by Csaba Osztrogonác
Modified: 2012-06-05 08:26 PDT (History)
3 users (show)

See Also:


Attachments
Patch (1.52 KB, patch)
2012-06-05 05:51 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
Patch (1.52 KB, patch)
2012-06-05 06:10 PDT, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2012-06-05 01:08:02 PDT
Now WebCore/bindings/scripts/preprocess-idls.pl works incorrectly on Qt Windows, 
because the generated WebKitBuild/Release/Source/WebCore/generated/idl_files.tmp
contains trailing whitespaces after filenames. It is generated by "GENERATOR 0"
in WebCore/DerivedSources.pri by simple echo.
Comment 1 Csaba Osztrogonác 2012-06-05 05:51:03 PDT
Created attachment 145771 [details]
Patch
Comment 2 Csaba Osztrogonác 2012-06-05 05:55:59 PDT
(In reply to comment #1)
> Created an attachment (id=145771) [details]
> Patch

(In reply to comment #1)
> Created an attachment (id=145771) [details]
> Patch

WebCore/bindings/scripts/preprocess-idls.pl can't handle "foo.idl " filenames, so we don't dump "foo.idl " names, but "foo.idl" names to idl_files.tmp.

The bug was caused by echo's different behaviour on Linux and Windows:
Linux's echo trims trailing whitespaces, but Windows' echo preserve all of them.
Comment 3 Tor Arne Vestbø 2012-06-05 06:01:25 PDT
Comment on attachment 145771 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=145771&action=review

> Source/WebCore/DerivedSources.pri:685
> +    # We need "$$binding " instead of "$$binding", because Windows' echo writes trailing whitespaces. (http://wkb.ug/88304)

Isn't the case that we need "$$binding", not "$$binding " with trailing space?

> Source/WebCore/DerivedSources.pri:686
> +    preprocessIdls.commands += echo $$binding>> $$IDL_FILES_TMP $$EOC

Can this be done by quoting instead?
Comment 4 Csaba Osztrogonác 2012-06-05 06:08:29 PDT
(In reply to comment #3)
> (From update of attachment 145771 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=145771&action=review
> 
> > Source/WebCore/DerivedSources.pri:685
> > +    # We need "$$binding " instead of "$$binding", because Windows' echo writes trailing whitespaces. (http://wkb.ug/88304)
> 
> Isn't the case that we need "$$binding", not "$$binding " with trailing space?

Good point. :)
 
> > Source/WebCore/DerivedSources.pri:686
> > +    preprocessIdls.commands += echo $$binding>> $$IDL_FILES_TMP $$EOC
> 
> Can this be done by quoting instead?
Unfortunately no.

echo "xxx" >1.txt --> 1.txt:"xxx" + the trailing whitespace 
(similar to ' instead of ")
Comment 5 Csaba Osztrogonác 2012-06-05 06:10:34 PDT
Created attachment 145776 [details]
Patch

Fixed typo
Comment 6 WebKit Review Bot 2012-06-05 08:26:23 PDT
Comment on attachment 145776 [details]
Patch

Clearing flags on attachment: 145776

Committed r119490: <http://trac.webkit.org/changeset/119490>
Comment 7 WebKit Review Bot 2012-06-05 08:26:35 PDT
All reviewed patches have been landed.  Closing bug.