Bug 87251 - [EFL][CMake] Integrate API unit tests with CTest
Summary: [EFL][CMake] Integrate API unit tests with CTest
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Thiago Marcos P. Santos
URL:
Keywords:
: 68511 (view as bug list)
Depends on: 68509
Blocks: 86092 87252
  Show dependency treegraph
 
Reported: 2012-05-23 05:04 PDT by Thiago Marcos P. Santos
Modified: 2012-07-03 09:21 PDT (History)
9 users (show)

See Also:


Attachments
Patch (2.82 KB, patch)
2012-07-02 05:25 PDT, Thiago Marcos P. Santos
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from gce-cr-linux-08 (425.31 KB, application/zip)
2012-07-02 06:06 PDT, WebKit Review Bot
no flags Details
Patch (2.83 KB, patch)
2012-07-02 11:47 PDT, Thiago Marcos P. Santos
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Marcos P. Santos 2012-05-23 05:04:28 PDT
CMake provides a nice built-in test runner that we should make use of it.
Comment 1 Thiago Marcos P. Santos 2012-07-02 05:25:46 PDT
Created attachment 150402 [details]
Patch
Comment 2 WebKit Review Bot 2012-07-02 06:06:49 PDT
Comment on attachment 150402 [details]
Patch

Attachment 150402 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/13125164

New failing tests:
fast/loader/loadInProgress.html
Comment 3 WebKit Review Bot 2012-07-02 06:06:53 PDT
Created attachment 150409 [details]
Archive of layout-test-results from gce-cr-linux-08

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: gce-cr-linux-08  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.39-gcg-201203291735-x86_64-with-Ubuntu-10.04-lucid
Comment 4 jochen 2012-07-02 07:03:56 PDT
Adam, something's fishy with the new cr-linux-ews bots
Comment 5 Adam Barth 2012-07-02 09:11:18 PDT
(In reply to comment #4)
> Adam, something's fishy with the new cr-linux-ews bots

Thanks.  /me will investigate.
Comment 6 Adam Barth 2012-07-02 09:32:05 PDT
Yes.  Turns out that test is very flaky on the bot.  I've marked it as flaky, which should silence it for now.
Comment 7 Daniel Bates 2012-07-02 11:40:47 PDT
Comment on attachment 150402 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=150402&action=review

OK.

> Source/WebKit/ChangeLog:3
> +        [EFL][CMake] Integrate API utests with CTest

Nit: utests => unit tests

> ChangeLog:3
> +        [EFL][CMake] Integrate API utests with CTest

Ditto.
Comment 8 Thiago Marcos P. Santos 2012-07-02 11:47:26 PDT
Created attachment 150457 [details]
Patch
Comment 9 WebKit Review Bot 2012-07-02 12:46:36 PDT
Comment on attachment 150457 [details]
Patch

Clearing flags on attachment: 150457

Committed r121702: <http://trac.webkit.org/changeset/121702>
Comment 10 WebKit Review Bot 2012-07-02 12:46:43 PDT
All reviewed patches have been landed.  Closing bug.
Comment 11 Thiago Marcos P. Santos 2012-07-03 09:21:57 PDT
*** Bug 68511 has been marked as a duplicate of this bug. ***