Bug 8518 - REGRESSION: Background image scales to size of containing DIV instead retaining it's original size
Summary: REGRESSION: Background image scales to size of containing DIV instead retaini...
Status: VERIFIED DUPLICATE of bug 8495
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Critical
Assignee: Nobody
URL: http://www.apple.com/science/
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-04-21 08:50 PDT by Chris Petersen
Modified: 2006-04-22 09:32 PDT (History)
2 users (show)

See Also:


Attachments
Reduced test case from apple site (357 bytes, text/html)
2006-04-21 08:51 PDT, Chris Petersen
no flags Details
Screen shot of scaled background images (15.55 KB, image/png)
2006-04-21 08:55 PDT, Chris Petersen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petersen 2006-04-21 08:50:27 PDT
At http://www.apple.com/science/, I noticed the background images used in the navigation bar are scaled with TOT Webkit.

Here is the structure of a reduced test case which I have attached.


<style type="text/css" >

div { width: 60px; height: 40px; background: url(http://images.apple.com/science/images/nav_links.gif) no-repeat; }


</style>
</head>
<body>

<div>
&nbsp

</div>
</body>
</html>
Comment 1 Chris Petersen 2006-04-21 08:51:36 PDT
Created attachment 7873 [details]
Reduced test case from apple site
Comment 2 Chris Petersen 2006-04-21 08:55:35 PDT
Created attachment 7874 [details]
Screen shot of scaled background images
Comment 3 Chris Petersen 2006-04-21 09:06:46 PDT
This is filed as <rdar://problem/4522644>
Comment 4 Chris Petersen 2006-04-21 09:26:38 PDT
This same issue with background images are occuring at other sites like http://www.apple.com/dotmac/ , http://www.macnn.com/ , and http://www.mozilla.com/.
Comment 5 Chris Petersen 2006-04-21 09:27:30 PDT
Setting to P1
Comment 6 Chris Petersen 2006-04-21 09:55:04 PDT
Based on my testing, the regression first started with the TOT Webkit NB r13966 (April 19th 5:23:40 GMT)
Comment 7 Darin Adler 2006-04-21 18:42:26 PDT
I think this is the same issue as bug 8508.
Comment 8 Darin Adler 2006-04-22 00:07:51 PDT

*** This bug has been marked as a duplicate of 8495 ***
Comment 9 Chris Petersen 2006-04-22 09:32:23 PDT
Verified as dup. This is fixed now on TOT Webkit.