Bug 8439 - GoogleTalk (GTalk) Quick Contacts not visible in GMail with Safari/WebKit
Summary: GoogleTalk (GTalk) Quick Contacts not visible in GMail with Safari/WebKit
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: GoogleBug, InRadar
: 12403 12880 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-04-17 09:52 PDT by Andre-John Mas
Modified: 2007-11-02 13:48 PDT (History)
12 users (show)

See Also:


Attachments
'Screen shot' showing the differences (113.70 KB, image/jpeg)
2006-04-17 09:54 PDT, Andre-John Mas
no flags Details
Contacts Still Overflowing with 15440 Latest Nightly (901.36 KB, image/jpeg)
2006-07-14 20:04 PDT, Shawn Smith
no flags Details
Email Topic Overflowing with Latest Night 15440 (752.41 KB, image/jpeg)
2006-07-14 20:06 PDT, Shawn Smith
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andre-John Mas 2006-04-17 09:52:56 PDT
I have both GTalk and GMail. With Firefox I see a 'Quick Contacts' list on the left hand side of the my GMail page, listing my active GTalk contacts. With Safari it is not displayed.

I would expect Safari to display this feature.

I can't tell whether Google disables this feature based on a feature test or a user-agent test.
Comment 1 Andre-John Mas 2006-04-17 09:54:56 PDT
Created attachment 7765 [details]
'Screen shot' showing the differences

This shows both the relevant section of the GMail page as seen in Safari and in Firefox.
Comment 2 Geoffrey Garen 2006-04-18 11:22:59 PDT
When spoofing as FF, TOT gets the contact list but it's formatted funny, overflowing the containing blue border. So there are two issues here: (1) Get GMail to stop blocking the contact list from Safari; (2) fix up the overflowing text.
Comment 3 Stephen Harbage 2006-05-11 08:59:37 PDT
Can someone please fix the overflowing text (afraid I haven't got a clue what to do)? I would love to see this working

(In reply to comment #2)
> When spoofing as FF, TOT gets the contact list but it's formatted funny,
> overflowing the containing blue border. So there are two issues here: (1) Get
> Gmail to stop blocking the contact list from Safari; (2) fix up the overflowing
> text.
> 

Comment 4 Adele Peterson 2006-05-11 14:58:09 PDT
Spoofing as FF, I don't see the overflowing text problem anymore.  If there aren't any other issues, we should talk to Google about unblocking TOT Safari.
Comment 5 Shawn Smith 2006-07-07 21:38:13 PDT
Any new action?
Comment 6 David Kilzer (:ddkilzer) 2006-07-12 21:58:20 PDT
GMail is Google.

Comment 7 Andre-John Mas 2006-07-13 16:31:25 PDT
any news on the 'overflowing text' issue?
Comment 8 Adele Peterson 2006-07-13 23:31:26 PDT
The overflowing text issue is fixed on TOT.  GTalk appears to work fine when you spoof as Firefox.

I'm not sure what communication there's been with Google about this issue.
Comment 9 David Kilzer (:ddkilzer) 2006-07-14 04:10:58 PDT
(In reply to comment #8)
> The overflowing text issue is fixed on TOT.  GTalk appears to work fine when
> you spoof as Firefox.
> 
> I'm not sure what communication there's been with Google about this issue.

This looks like it may be an easy fix on Google's side:  allowing another user agent to view the content.  Adding Bob Austin to the CC list.  (I'm resisting changing this to an Evangelism bug.)

Comment 10 Joost de Valk (AlthA) 2006-07-14 04:12:01 PDT
If it has the GoogleBug keyword, Google people will see it :)
Comment 11 Geoffrey Garen 2006-07-14 11:01:29 PDT
Though the overflow issue is fixed, the page is slightly off because the blue border doesn't appear to the right of the contacts list. This looks like a minor metrics problem in the page or in WebKit. Hopefully the GOOG folks can shed some light.
Comment 12 Shawn Smith 2006-07-14 20:04:59 PDT
Created attachment 9459 [details]
Contacts Still Overflowing with 15440 Latest Nightly

With the latest nightly 15440 spoofing as: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2, the Quicklist is still cut off as displayed in the attachement.
Comment 13 Shawn Smith 2006-07-14 20:06:03 PDT
Created attachment 9460 [details]
Email Topic Overflowing with Latest Night 15440

With the latest nightly 15440 spoofing as: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2, the Topic is still overflowing as displayed in the attachement.
Comment 14 Shawn Smith 2006-07-14 20:07:16 PDT
(In reply to comment #12)
> Created an attachment (id=9459) [edit]
> Contacts Still Overflowing with 15440 Latest Nightly
> 
> With the latest nightly 15440 spoofing as: Mozilla/5.0 (Macintosh; U; PPC Mac
> OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2, the Quicklist is
> still cut off as displayed in the attachement.
> 

Cut off should read as OVERFLOW.
Comment 15 David Kilzer (:ddkilzer) 2007-01-25 10:00:38 PST
*** Bug 12403 has been marked as a duplicate of this bug. ***
Comment 16 David Kilzer (:ddkilzer) 2007-01-25 10:06:42 PST
Per Comment #8, this appears to be an evangelism bug since the GoogleTalk Quick Contacts box appears when Safari/WebKit is spoofed as Firefox.  (Not sure if the Quick Contacts work as expected when spoofing, though.)

Comment 17 Curt Broskey 2007-01-25 10:25:23 PST
Can this be fixed or is this a Google issue and not a Safari issue?  I just think it's interesting that FireFox has no issue.  But I am not a coder.
Comment 18 David Kilzer (:ddkilzer) 2007-01-25 10:39:26 PST
(In reply to comment #17)
> Can this be fixed or is this a Google issue and not a Safari issue?  I just
> think it's interesting that FireFox has no issue.  But I am not a coder.

I'm inclined to think that this is a Google issue and not a Safari/WebKit issue, but it could be a chicken-and-egg problem where WebKit doesn't support something that the Quick Contacts needs, so Google hasn't enabled it for Safari/WebKit yet.

Comment 19 mitz 2007-02-24 14:31:04 PST
*** Bug 12880 has been marked as a duplicate of this bug. ***
Comment 20 Curt Broskey 2007-03-09 08:38:48 PST
I am just curious if there has been any conclusion to this.  Are we all thinking it's a Google issue?
Comment 21 Alice Liu 2007-04-10 11:29:09 PDT
<rdar://problem/4442536>
Comment 22 Curt Broskey 2007-04-10 13:26:07 PDT
(In reply to comment #21)
> <rdar://problem/4442536>
> 

Does this mean it has been flagged in Apple's Radar system?
Comment 23 Mark Malone 2007-04-10 13:35:53 PDT
yes
Comment 24 Vincent Noel 2007-11-02 12:39:10 PDT
The new version of Gmail (http://googlesystem.blogspot.com/2007/10/next-version-of-gmail-will-be-faster.html) that Google is rolling out makes the GTalk quick contacts work under Safari 3.0. At least it's working for me.
So apparently Google has fixed this bug from their side. I can't decide if this bug should be kept open to make chat work for users of the older gmail version or not.
Comment 25 Andre-John Mas 2007-11-02 13:15:48 PDT
As the person who reported the issue, I can now say 'works for me' with Safari 3.0, on Leopard, and Google's updated version of Google Mail (GMail).

Who is responsible for marking this bug as fixed? The reporter or someone else?
Comment 26 David Kilzer (:ddkilzer) 2007-11-02 13:28:02 PDT
(In reply to comment #25)
> Who is responsible for marking this bug as fixed? The reporter or someone else?

If you feel it's fixed, please close it.  If someone disagrees with you, they will reopen it or file a new bug.  (I don't think that will happen in this case. :)

Comment 27 Andre-John Mas 2007-11-02 13:48:36 PDT
It works for me and seems to be working for others. Marking as fixed.