Bug 12403 - GoogleTalk not showing up on left side when in gMail webpage
Summary: GoogleTalk not showing up on left side when in gMail webpage
Status: RESOLVED DUPLICATE of bug 8439
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 420+
Hardware: Macintosh PowerPC OS X 10.4
: P2 Major
Assignee: Nobody
URL: http://mail.google.com/mail/
Keywords: GoogleBug
Depends on:
Blocks:
 
Reported: 2007-01-25 06:49 PST by Curt Broskey
Modified: 2007-03-09 15:39 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Curt Broskey 2007-01-25 06:49:48 PST
This was happening in all versions of Safari.  When logged in to google mail the gtalk list does not come up nor can you chat using safari.  I tested this in FireFox and it works with out issue.
Comment 1 David Kilzer (:ddkilzer) 2007-01-25 07:24:18 PST
Confirmed using a locally-built debug build of WebKit r19107 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8L127).

There is a rounded-edge box between the "Contacts" link and the "Labels" box on the left side of the screen.  I'm not sure if this feature is simply disabled for WebKit/Safari, or whether it's an actual WebKit bug, though.  (If it's disabled for WebKit/Safari, then this would be an evangelism bug.)

I did see this JavaScript error after logging into GMail, but I'm not sure if it happened immediately after I loaded the page:

[13326] http://mail.google.com/mail/?auth=DQAAAHgAAAAVpUAnAnnN-j1e8rr2TQg7mmwmDnx6Wd4YsOIqY6Rb-wqFkcIBgkZLTec7LV9eTRaOQJpoeYpTE6rKzjDq-cye-zelWv5ivM2GDrXyhBGM5_EOVsv1OGmmpQC6LFSFebhhUnXtzBkbblnLyPtnaoQkpeyUpoz7r3zkNIdziyzGHQ line 9: TypeError: Null value

JavaScript Console output:

TypeError: Null value
http://mail.google.com/mail/?view=page&name=loading&ver=1q2chc66hnxek
Line: 9

Happens in the only line in this JavaScript function:

function SetClass(id, c) {
  document.getElementById(id).className = c;
}

Haven't debugged it any further.

Comment 2 mitz 2007-01-25 09:14:42 PST
Bug 8439?
Comment 3 David Kilzer (:ddkilzer) 2007-01-25 10:00:38 PST

*** This bug has been marked as a duplicate of 8439 ***
Comment 4 David Kilzer (:ddkilzer) 2007-01-25 10:08:08 PST
(In reply to comment #1)
> Haven't debugged it any further.

This code appears to be related to the page loading ("Loading...") when GMail opens and not to the Quick Contacts box.

Comment 5 Curt Broskey 2007-01-25 10:24:41 PST
Can this be fixed or is this a Google issue and not a Safari issue?  I just think it's interesting that FireFox has no issue.  But I am not a coder.
Comment 6 Curt Broskey 2007-03-09 08:38:03 PST
I am just curious if there has been any conclusion to this.  Are we all thinking it's a Google issue?
Comment 7 David Kilzer (:ddkilzer) 2007-03-09 09:05:18 PST
(In reply to comment #6)
> I am just curious if there has been any conclusion to this.  Are we all
> thinking it's a Google issue?

Yes, Google must enable this for Safari users.  If you spoof Safari as Mozilla or Firefox, I believe it shows up (although I'm not sure if it works after showing up).

http://bugs.webkit.org/show_bug.cgi?id=8439#c8
http://bugs.webkit.org/show_bug.cgi?id=8439#c18

Comment 8 Curt Broskey 2007-03-09 10:55:51 PST
I tried spoofing and got a weird message in orange on top that said "For a better Gmail experience, use a fully supported browser."  So spoofing will not work either.  I wonder how we would let Google know about this and actually get a response.

- CB
Comment 9 David Kilzer (:ddkilzer) 2007-03-09 15:39:46 PST
(In reply to comment #8)
> I tried spoofing and got a weird message in orange on top that said "For a
> better Gmail experience, use a fully supported browser."  So spoofing will not
> work either.

I think Safari 3.0 has the ability to spoof as Firefox, which works "better".

> I wonder how we would let Google know about this and actually get
> a response.

Google is aware of the issue--see the CC list.