Bug 82239 - [chromium] assertion being hit in CCLayerTreeHost::updateCompositorResources
Summary: [chromium] assertion being hit in CCLayerTreeHost::updateCompositorResources
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dana Jansens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-26 13:39 PDT by Shawn Singh
Modified: 2012-03-26 15:44 PDT (History)
8 users (show)

See Also:


Attachments
Patch (1.85 KB, patch)
2012-03-26 14:57 PDT, Dana Jansens
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Singh 2012-03-26 13:39:02 PDT
Here is another assertion i'm hitting on desktop aura...

I'm not sure if this should be merged with https://bugs.webkit.org/show_bug.cgi?id=82237  so just in case I'm reporting them separately.

around line 582, in CCLayerTreeHost::updateCompositorResources
ASSERT(it->renderSurface()->drawOpacity() || it->drawOpacityIsAnimating())


To reproduce:

1. load www.apple.com/iphone
2. enjoy it for a while, navigate back and forth between the ads.  maybe try resizing if needed
3. eventually it crashes on this assertion.
Comment 1 Dana Jansens 2012-03-26 13:44:14 PDT

*** This bug has been marked as a duplicate of bug 81994 ***
Comment 2 Dana Jansens 2012-03-26 13:44:29 PDT
Already fixed :)
Comment 3 Dana Jansens 2012-03-26 13:45:39 PDT
Ohhh same wrong assert. 2nd copy.
Comment 4 Nat Duca 2012-03-26 14:52:21 PDT
Dana has a fix pending, 10min
Comment 5 Dana Jansens 2012-03-26 14:57:36 PDT
Created attachment 133900 [details]
Patch
Comment 6 Adrienne Walker 2012-03-26 14:58:53 PDT
Comment on attachment 133900 [details]
Patch

R=me.
Comment 7 WebKit Review Bot 2012-03-26 15:43:58 PDT
Comment on attachment 133900 [details]
Patch

Clearing flags on attachment: 133900

Committed r112159: <http://trac.webkit.org/changeset/112159>
Comment 8 WebKit Review Bot 2012-03-26 15:44:02 PDT
All reviewed patches have been landed.  Closing bug.