Bug 81945 - fast/events/suspend-timers.html is failing in Mac WebKit2, even though LayoutTestController.overridePreference is implemented in WebKitTestRunner
: fast/events/suspend-timers.html is failing in Mac WebKit2, even though Layout...
Status: RESOLVED FIXED
: WebKit
Tools / Tests
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
: InRadar, LayoutTestFailure
:
:
  Show dependency treegraph
 
Reported: 2012-03-22 12:01 PST by
Modified: 2012-04-17 16:08 PST (History)


Attachments
Patch (3.15 KB, patch)
2012-04-14 05:21 PST, Zalan Bujtas
no flags Review Patch | Details | Formatted Diff | Diff
Patch (3.16 KB, patch)
2012-04-14 10:36 PST, Zalan Bujtas
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2012-03-22 12:01:40 PST
fast/events/suspend-timers.html is failing in Mac WebKit2, but passes in Safari. The test relies on enabling the page cache using layoutTestController.overridePreference('WebKitUsesPageCachePreferenceKey', 1). Even though this function is implemented in WebKitTestRunner, it may not be achieving the desired effect.
------- Comment #1 From 2012-03-22 12:02:04 PST -------
<rdar://problem/11101498>
------- Comment #2 From 2012-03-22 12:04:49 PST -------
Added the current incorrect results as Mac WebKit2 expected results in <http://trac.webkit.org/r111741>.
------- Comment #3 From 2012-03-22 14:08:39 PST -------
The failing results are inconsistent, so I am going to skip the test in Mac WebKit2.
------- Comment #4 From 2012-03-22 14:11:34 PST -------
Added to the Mac WebKit2 skip list in <http://trac.webkit.org/r111761>.
------- Comment #5 From 2012-04-14 05:21:47 PST -------
Created an attachment (id=137208) [details]
Patch
------- Comment #6 From 2012-04-14 05:24:44 PST -------
Alternatively, CacheModel can be set to PrimaryWebBrowser, only when the PageCache's preference key is also set to enabled. Though, I believe it's better to run WebKitTestRunner with PrimaryWebBrowser setting instead of that DocumentViewer.
------- Comment #7 From 2012-04-14 05:25:57 PST -------
*** Bug 81637 has been marked as a duplicate of this bug. ***
------- Comment #8 From 2012-04-14 09:52:47 PST -------
(From update of attachment 137208 [details])
It looks like DumpRenderTree (on Mac, at least) uses WebCacheModelDocumentBrowser. Shouldn’t WebKitTestRunner use the same by default?
------- Comment #9 From 2012-04-14 10:18:44 PST -------
(In reply to comment #8)
> (From update of attachment 137208 [details] [details])
> It looks like DumpRenderTree (on Mac, at least) uses WebCacheModelDocumentBrowser. Shouldn’t WebKitTestRunner use the same by default?

The only reason I picked PrimaryWebBrowser was because it guarantees capacity > 0. However for compatibility reasons, i guess DocumentBrowser is a better pick.
------- Comment #10 From 2012-04-14 10:36:09 PST -------
Created an attachment (id=137213) [details]
Patch
------- Comment #11 From 2012-04-14 11:29:35 PST -------
(From update of attachment 137213 [details])
Clearing flags on attachment: 137213

Committed r114206: <http://trac.webkit.org/changeset/114206>
------- Comment #12 From 2012-04-14 11:29:41 PST -------
All reviewed patches have been landed.  Closing bug.
------- Comment #13 From 2012-04-17 16:02:11 PST -------
This commit broke the LayoutTests/fast/harness/use-page-cache.html test on Lion and Snow Leopard.

See: http://build.webkit.org/results/Lion%20Debug%20(WebKit2%20Tests)/r114298%20(6058)/results.html
------- Comment #14 From 2012-04-17 16:08:58 PST -------
Filed <https://bugs.webkit.org/show_bug.cgi?id=84206> to track the test failure.