As discussed with Antti, we should remove SVGGenericAnimatedType, and the associated reinterpret_cast, and replace it with a type-safe solution, even if it requires some boilerplate code.
It was a poor decision to go with it initially, so I'm going to redesign it.
Created attachment 132794 [details]
Comment on attachment 132794 [details]
r=me, with naming consistency fixes discussed in irc
Committed r111380: <http://trac.webkit.org/changeset/111380>