Bug 8077 - New TextField allows bold and italic styles.
Summary: New TextField allows bold and italic styles.
Status: RESOLVED DUPLICATE of bug 6989
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-03-30 07:29 PST by Todd Yandell
Modified: 2006-07-06 18:22 PDT (History)
2 users (show)

See Also:


Attachments
Testcase (550 bytes, text/html)
2006-03-30 07:41 PST, Todd Yandell
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Todd Yandell 2006-03-30 07:29:17 PST
The new TextField in WebKit allows the user to change the style of the text. For example, you can highlight a portion of a TextField's text, and press Cmd-B to make it bold. The style will be kept until the TextField loses focus. At that point the style is removed, but the characters are still laid out as if the style was applied. Styles are also not (immediately) removed when rich text is pasted into the text field.
Comment 1 Todd Yandell 2006-03-30 07:41:09 PST
Created attachment 7390 [details]
Testcase
Comment 2 Mark Rowe (bdash) 2006-07-06 18:22:01 PDT

*** This bug has been marked as a duplicate of 6989 ***