Bug 6989 - REGRESSION: Plain-text mode needed for contenteditable area used in new text field
Summary: REGRESSION: Plain-text mode needed for contenteditable area used in new text ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Justin Garcia
URL:
Keywords: InRadar, Regression
: 8077 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-01-31 19:01 PST by Adele Peterson
Modified: 2006-07-06 18:22 PDT (History)
3 users (show)

See Also:


Attachments
patch (12.68 KB, patch)
2006-03-24 05:14 PST, Justin Garcia
no flags Details | Formatted Diff | Diff
patch (12.68 KB, patch)
2006-03-24 05:19 PST, Justin Garcia
no flags Details | Formatted Diff | Diff
patch (39.26 KB, patch)
2006-03-30 03:47 PST, Justin Garcia
no flags Details | Formatted Diff | Diff
patch (39.23 KB, patch)
2006-03-30 03:59 PST, Justin Garcia
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2006-01-31 19:01:25 PST
We don't want to allow any rich text in our new text fields.

- no pasting in rich content
- no using execCommand to make the text rich. (I think this covers using cmd-b, etc)
Comment 1 Adele Peterson 2006-02-15 20:07:13 PST
Hmm- i might be wrong about execCommand.  We definitely want to disallow keyboard commands that make the text rich.
Comment 2 Adele Peterson 2006-03-01 17:01:35 PST
<rdar://problem/4463526> Plain-text mode needed for contenteditable area used in new text field (6989)
Comment 3 Justin Garcia 2006-03-24 05:14:26 PST
Created attachment 7279 [details]
patch

This is a patch w/o deciding on how plaintext mode will be turned on.
Comment 4 Justin Garcia 2006-03-24 05:19:20 PST
Created attachment 7280 [details]
patch
Comment 5 Adele Peterson 2006-03-29 17:50:05 PST
Bumping to P1 since this causes a text field regression
Comment 6 Justin Garcia 2006-03-30 03:47:15 PST
Created attachment 7386 [details]
patch
Comment 7 Justin Garcia 2006-03-30 03:59:14 PST
Created attachment 7387 [details]
patch
Comment 8 Darin Adler 2006-03-30 08:37:14 PST
Comment on attachment 7387 [details]
patch

What you call Richly I would have called "WithStyle" ;-)

r=me
Comment 9 Mark Rowe (bdash) 2006-07-06 18:22:01 PDT
*** Bug 8077 has been marked as a duplicate of this bug. ***