Even when the shadow DOM API is disabled, the <content> element exhibits traits of something other than HTMLUnknownElement: http://jsfiddle.net/dglazkov/dmXVf/
I'm working on this.
Created attachment 130246 [details] Patch
Comment on attachment 130246 [details] Patch Attachment 130246 [details] did not pass mac-ews (mac): Output: http://queues.webkit.org/results/11837079
Comment on attachment 130246 [details] Patch Attachment 130246 [details] did not pass win-ews (win): Output: http://queues.webkit.org/results/11833099
Comment on attachment 130246 [details] Patch Attachment 130246 [details] did not pass qt-ews (qt): Output: http://queues.webkit.org/results/11832096
Comment on attachment 130246 [details] Patch Attachment 130246 [details] did not pass efl-ews (efl): Output: http://queues.webkit.org/results/11839156
Created attachment 130321 [details] Patch
Comment on attachment 130321 [details] Patch Attachment 130321 [details] did not pass qt-ews (qt): Output: http://queues.webkit.org/results/11839242
Comment on attachment 130321 [details] Patch Attachment 130321 [details] did not pass win-ews (win): Output: http://queues.webkit.org/results/11839243
Created attachment 130339 [details] Patch
Comment on attachment 130339 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=130339&action=review > Source/WebCore/ChangeLog:9 > + which allows HTMLElementFactory and HTMLElementWrapperFacotry to check RuntimeEnabledFeatures Facotry -> Factory > Source/WebCore/html/HTMLTagNames.in:97 > +shadow interfaceName=HTMLShadowElement, conditional=SHADOW_DOM, runtimeFeature=shadowDOM Adam already added runtimeConditional flag in http://trac.webkit.org/changeset/106603, so let's use that instead.
Adam, Haraken -- could you take a look at the generator code?
Comment on attachment 130339 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=130339&action=review This looks fine. make_names.pl is something of a disaster file, but I haven't worked up the steam to clean it up yet. >> Source/WebCore/html/HTMLTagNames.in:97 >> +shadow interfaceName=HTMLShadowElement, conditional=SHADOW_DOM, runtimeFeature=shadowDOM > > Adam already added runtimeConditional flag in http://trac.webkit.org/changeset/106603, so let's use that instead. Yeah, I think runtimeConditional is a slightly better name.
Dimitri, Adam, thanks for taking a look! (In reply to comment #13) > (From update of attachment 130339 [details]) > View in context: https://bugs.webkit.org/attachment.cgi?id=130339&action=review > > This looks fine. make_names.pl is something of a disaster file, but I haven't worked up the steam to clean it up yet. True. People who don't know perl like me have made such a disaster... > > >> Source/WebCore/html/HTMLTagNames.in:97 > >> +shadow interfaceName=HTMLShadowElement, conditional=SHADOW_DOM, runtimeFeature=shadowDOM > > > > Adam already added runtimeConditional flag in http://trac.webkit.org/changeset/106603, so let's use that instead. > > Yeah, I think runtimeConditional is a slightly better name. Great! I'll rename it before landing.
Created attachment 130479 [details] Patch for landing
Comment on attachment 130479 [details] Patch for landing Clearing flags on attachment: 130479 Committed r110014: <http://trac.webkit.org/changeset/110014>
All reviewed patches have been landed. Closing bug.