Bug 79730 - Dynamically adding content to an element does not remove the :empty styling
Summary: Dynamically adding content to an element does not remove the :empty styling
Status: RESOLVED DUPLICATE of bug 79734
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL: http://jsfiddle.net/gaby/BSbEw/
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-27 18:33 PST by Gabriele
Modified: 2012-02-27 19:08 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriele 2012-02-27 18:33:40 PST
Other browsers tested:
  Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5 / Chrome: FAIL
  Firefox 4.x: OK
     IE 7/8/9: (7/8 FAIL) - (9 OK)

What steps will reproduce the problem?
1.set an :empty CSS rule, for some element , with display:none
2.dynamically set the content of that element with javascript


What is the expected result?
Once content is added dynamically the element should lose the :empty styling

What happens instead?
The element remains display:none


It is similar to https://bugs.webkit.org/show_bug.cgi?id=26570 but for dynamic content..
Comment 1 noel gordon 2012-02-27 19:08:50 PST

*** This bug has been marked as a duplicate of bug 79734 ***