Bug 78679 - Clean up radio button tests
Summary: Clean up radio button tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Kent Tamura
URL:
Keywords:
Depends on:
Blocks: 78678
  Show dependency treegraph
 
Reported: 2012-02-15 01:07 PST by Kent Tamura
Modified: 2012-02-15 06:36 PST (History)
3 users (show)

See Also:


Attachments
Patch (761.41 KB, patch)
2012-02-15 01:11 PST, Kent Tamura
no flags Details | Formatted Diff | Diff
Patch 2 (761.91 KB, patch)
2012-02-15 03:35 PST, Kent Tamura
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Tamura 2012-02-15 01:07:42 PST
Clean up radio button tests
Comment 1 Kent Tamura 2012-02-15 01:11:26 PST
Created attachment 127130 [details]
Patch
Comment 2 Kentaro Hara 2012-02-15 01:31:59 PST
Comment on attachment 127130 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=127130&action=review

r- due to missing the diff of radio-nested-labels.html

> LayoutTests/ChangeLog:9
> +        - Split checkbox-radio-onchange.html into two.
> +        - Convert some rendering tests about radio buttons to text tests.

Maybe I wanted to see more descriptive comments. At least,

- Split checkbox-radio-onchange.html into checkbox-onchange.html and radio-onchange.html.
- Convert radio_checked.html and radio_checked_dynamic.html to text tests.

> LayoutTests/ChangeLog:19
> +        * fast/forms/radio-nested-labels.html:

This change is recognized as a binary change and I cannot see it. Would you paste the diff in comments?

> LayoutTests/fast/forms/radio-attr-order.html:6
> +<input type="radio" checked name="test_group" id="rb">

Nit: name= is not necessary.

> LayoutTests/fast/forms/radio/radio-onchange.html:7
> +<input type="radio" name="test" id="rd">

Nit: You can remove this line.

> LayoutTests/fast/forms/radio/radio-onchange.html:8
> +<input type="radio" name="test" id="rd2" onchange="handleChange()">

Nit: name= is not necessary.
Comment 3 Kent Tamura 2012-02-15 01:43:35 PST
(In reply to comment #2)
> (From update of attachment 127130 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=127130&action=review
> 
> r- due to missing the diff of radio-nested-labels.html

Oh, svn:mime-type of radio-nested-labels.html is application/octet-stream...

> > LayoutTests/fast/forms/radio-attr-order.html:6
> > +<input type="radio" checked name="test_group" id="rb">
> 
> Nit: name= is not necessary.

Existence of name attribute affects the behavior of radio buttons in some cases.  We should not change it.
Comment 4 Kent Tamura 2012-02-15 03:35:25 PST
Created attachment 127152 [details]
Patch 2
Comment 5 Kentaro Hara 2012-02-15 03:51:18 PST
Comment on attachment 127152 [details]
Patch 2

Looks OK!
Comment 6 Kent Tamura 2012-02-15 04:20:18 PST
Comment on attachment 127152 [details]
Patch 2

Thank you for reviewing!
Comment 7 WebKit Review Bot 2012-02-15 05:39:48 PST
Comment on attachment 127152 [details]
Patch 2

Clearing flags on attachment: 127152

Committed r107805: <http://trac.webkit.org/changeset/107805>
Comment 8 WebKit Review Bot 2012-02-15 05:39:56 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 WebKit Review Bot 2012-02-15 06:36:56 PST
The commit-queue encountered the following flaky tests while processing attachment 127152 [details]:

animations/suspend-resume-animation-events.html bug 51002 (author: cmarrin@apple.com)
The commit-queue is continuing to process your patch.