Bug 77635 - [CSS Filters] Text selection caret should use computeRectForRepaint
: [CSS Filters] Text selection caret should use computeRectForRepaint
Status: RESOLVED DUPLICATE of bug 80323
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To: Nobody
Depends on:
  Show dependency treegraph
Reported: 2012-02-02 05:38 PST by Alexandru Chiculita
Modified: 2012-03-30 13:05 PDT (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Alexandru Chiculita 2012-02-02 05:38:04 PST
Currently the caret drawing uses a combination of offsetFromContainer and localToAbsoluteQuad to find out the repaint rectangle of the caret. Use computeRectForRepaint to make sure the filters (and RenderFlowThread for regions) can compute the correct repaint rectangle.
Comment 1 Alexandru Chiculita 2012-03-30 13:05:12 PDT
80323 should fix this one because we are catching all the repaints as if that layer was the repaint container. This is similar to how composited layers filter the repaints. I've just tested it and this bug is fixed when the patch on 80323 is applied.

*** This bug has been marked as a duplicate of bug 80323 ***