Bug 77005 - [GStreamer] 0.11 support for Media elements
Summary: [GStreamer] 0.11 support for Media elements
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 77085 77086 77087 77088 77089 84029
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-25 06:40 PST by Philippe Normand
Modified: 2012-06-19 19:48 PDT (History)
4 users (show)

See Also:


Attachments
Patch (59.95 KB, patch)
2012-01-25 08:01 PST, Philippe Normand
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Normand 2012-01-25 06:40:52 PST
We should support the 0.11 APIs.
A ./configure --with-gstreamer=0.11 could be used to build (defaulting to 0.10).

For video rendering we will need a new video-sink that will initially provide the same features as the current 0.10 video-sink.
Comment 1 Philippe Normand 2012-01-25 06:58:19 PST
Also, the GStreamerGWorld module is not really worth porting as it's planned to be removed soon.
Comment 2 Philippe Normand 2012-01-25 08:01:13 PST
Created attachment 123944 [details]
Patch

First iteration :)
Comment 3 Philippe Normand 2012-01-25 08:05:50 PST
I can probably find a way to split this patch if needed.
Comment 4 WebKit Review Bot 2012-01-25 08:06:03 PST
Attachment 123944 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'ChangeLog', u'Source/WebCore/ChangeLog', u..." exit_code: 1

Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:67:  webkit_video_sink_signals is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:71:  timeout_id is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:72:  buffer_mutex is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:73:  data_cond is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:331:  need_pool is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:362:  n_param_values is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:363:  invocation_hint is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:387:  gobject_class is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:388:  gstbase_sink_class is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Source/WebCore/platform/graphics/gstreamer/VideoSinkGStreamer1.cpp:389:  element_class is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 10 in 22 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Philippe Normand 2012-01-26 02:55:11 PST
I'm going to split this in 4 patches:

- build infrastructure
- webkitwebsrc changes
- video-sink
- disable GStreamerGWorld
Comment 6 Philippe Normand 2012-01-26 03:32:54 PST
Comment on attachment 123944 [details]
Patch

Went through the patch split machine.
Comment 7 Philippe Normand 2012-06-19 19:48:12 PDT
Last patch landed. Next step would be to have test coverage on the bots. I'll file a separate bug for this.