Bug 76817 - [GTK] run-gtk-tests randomly fails while running the xprop comand
Summary: [GTK] run-gtk-tests randomly fails while running the xprop comand
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Mario Sanchez Prada
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2012-01-23 01:36 PST by Mario Sanchez Prada
Modified: 2012-01-23 06:36 PST (History)
3 users (show)

See Also:


Attachments
Comment ATSPI related lines in run-gtk-tests (4.49 KB, patch)
2012-01-23 01:57 PST, Mario Sanchez Prada
pnormand: review+
Details | Formatted Diff | Diff
Don't use xprop in run-gtk-test (not needed) (4.57 KB, patch)
2012-01-23 06:09 PST, Mario Sanchez Prada
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mario Sanchez Prada 2012-01-23 01:36:35 PST
Since the patch for bug 72589 got in, the GTK bots have been randomly failing sometimes because of the run-gtk-scripts sometimes (I still don't understand the reason behind it) fails to execute the xprop command, which it needs to run to make sure that there is no ATSPI accessibility bus already launched.

As the problem is not related to the WK2GTK a11y code itself, but to the run-gtk-tests script (when it runs properly, the WK2 a11y test passes), my proposal is to create a patch now for commenting the offending lines in run-gtk-tests and keep this bug open once it gets in, so we can work on getting a not randomly failing version of that script without having the bots red in the meanwhile.
Comment 1 Mario Sanchez Prada 2012-01-23 01:49:25 PST
For reference, this is the error that is happening in the bots when this command fails:

  Skipping test unittests/testdownload
  Skipping test unittests/testwebview
  Skipping test unittests/testwebresource
  Traceback (most recent call last):
    File "./Tools/Scripts/run-gtk-tests", line 147, in <module>
      sys.exit(TestRunner().run())
    File "./Tools/Scripts/run-gtk-tests", line 97, in run
      self._executive.run_command(['xprop', '-root', '-remove', 'AT_SPI_BUS'], env=test_env)
    File "/var/lib/buildbot/build/gtk-linux-32-release/build/Tools/Scripts/webkitpy/common/system/executive.py", line 440, in run_command
      (error_handler or self.default_error_handler)(script_error)
    File "/var/lib/buildbot/build/gtk-linux-32-release/build/Tools/Scripts/webkitpy/common/system/executive.py", line 357, in default_error_handler
      raise error
  webkitpy.common.system.executive.ScriptError: Failed to run "[u'xprop', u'-root', u'-remove', u'AT_SPI_BUS']"  exit_code: 1

Surprisingly, if I log in the bot and manually run Xvfb once, the error will go away... perhaps a race condition between running Xvfb and running the xprop command?
Comment 2 Mario Sanchez Prada 2012-01-23 01:57:38 PST
Created attachment 123531 [details]
Comment ATSPI related lines in run-gtk-tests
Comment 3 Mario Sanchez Prada 2012-01-23 02:05:41 PST
Committed r105601: <http://trac.webkit.org/changeset/105601>
Comment 4 Mario Sanchez Prada 2012-01-23 06:09:44 PST
Created attachment 123546 [details]
Don't use xprop in run-gtk-test (not needed)
Comment 5 Gustavo Noronha (kov) 2012-01-23 06:16:51 PST
Comment on attachment 123546 [details]
Don't use xprop in run-gtk-test (not needed)

OK
Comment 6 Mario Sanchez Prada 2012-01-23 06:36:16 PST
Committed r105617: <http://trac.webkit.org/changeset/105617>