Bug 76007 - Audio with HTML5 do not work with latest webkit on N9 Qt HTML application
Summary: Audio with HTML5 do not work with latest webkit on N9 Qt HTML application
Status: RESOLVED DUPLICATE of bug 53682
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Other
: P2 Normal
Assignee: Nobody
URL:
Keywords: HTML5, Qt
Depends on:
Blocks:
 
Reported: 2012-01-10 16:24 PST by Rahul
Modified: 2012-02-10 06:16 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rahul 2012-01-10 16:24:54 PST
Latest version of libqt4webkit fails to play audio. I concluded this as the same Qt/Html5 application works fine with older images (wk 40 or wk 41).

Week 41 or earlier have libqt4webkit~2.1.x and latest images have libqt4webkit~2.2.x. I am not sure about actual reason but when I downgraded webkit on N9 with latest images, my application worked fine. So I believe its fair enough to blame latest version of Webkit for audio failure with HTML5 Qt application
Comment 1 Bruno Abinader (history only) 2012-01-20 07:52:58 PST
Hi Rahul, thank you for the feedback. I've found out that a specific commit 429bbaa92d60a22a2264e0a1d909dd3f070249a7 from 2.1 branch is not merged into 2.2, which is a workaround for QtMultimedia bug (QTMOBILITY-1090). As the commit log says, a previous WebKit bug 53682 has been created for this. We're going to handle this internally.

*** This bug has been marked as a duplicate of bug 53682 ***