Bug 53682 - [Qt][Symbian] HTML5 audio/video can't play after click the play button
Summary: [Qt][Symbian] HTML5 audio/video can't play after click the play button
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media Elements (show other bugs)
Version: 528+ (Nightly build)
Hardware: All OS X 10.5
: P2 Normal
Assignee: Yi Shen
URL:
Keywords:
: 76007 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-03 07:12 PST by Yi Shen
Modified: 2012-01-20 07:52 PST (History)
6 users (show)

See Also:


Attachments
pre-roll to get the correct buffer-status (1.50 KB, patch)
2011-02-03 07:22 PST, Yi Shen
no flags Details | Formatted Diff | Diff
put a reference to the QtMobility bug (1.66 KB, patch)
2011-02-03 07:48 PST, Yi Shen
vestbo: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yi Shen 2011-02-03 07:12:41 PST
In Qt Webkit the implementation is expecting BufferedMedia notification on load.  If it doesn’t receive the BufferedMedia status then it won’t play at all (because it is waiting for enough data to play). This is how it works on Linux and other platforms we’ve tried, however, on symbian platform, it never gets BufferedMedia status if NOT call QMediaPlayer::play() (http://bugreports.qt.nokia.com/browse/QTMOBILITY-1090), so the video/audio won't play after click the play button (it is a chicken-and-egg problem). Since it is the behaviour of symbian APIs (which may take a while for fixing), we want to put a very simple workaround to solve this issue for symbian. The patch is coming soon.
Comment 1 Yi Shen 2011-02-03 07:22:15 PST
Created attachment 81058 [details]
pre-roll to get the correct  buffer-status
Comment 2 Nancy Piedra 2011-02-03 07:40:52 PST
Yi, can we put a reference to the QtMobility bug (QTMOBLITY-1090) in the code?

That way we'll remember why we did it.
Comment 3 Yi Shen 2011-02-03 07:48:46 PST
Created attachment 81060 [details]
put a reference to the QtMobility bug
Comment 4 Tor Arne Vestbø (not active) 2011-02-07 07:24:16 PST
Comment on attachment 81060 [details]
put a reference to the QtMobility bug

This should be solved in QtMultimedia, not WebKit
Comment 5 Suresh Voruganti 2011-02-08 12:12:58 PST
Removing error from Qtwebkit 2.1.1 master bug
Comment 6 Ademar Reis 2011-02-09 11:50:55 PST
(In reply to comment #5)
> Removing error from Qtwebkit 2.1.1 master bug

Adding back, as it'll be added as a workaround on 2.1.x. If it's really not going to be applied on trunk (not even with some sort of #ifdef), then please close this bug as WONTFIX.
Comment 7 Tor Arne Vestbø (not active) 2011-02-09 12:48:12 PST
(In reply to comment #6)
> (In reply to comment #5)
> > Removing error from Qtwebkit 2.1.1 master bug
> 
> Adding back, as it'll be added as a workaround on 2.1.x. If it's really not going to be applied on trunk (not even with some sort of #ifdef), then please close this bug as WONTFIX.

Your wish is my command!
Comment 8 Ademar Reis 2011-02-14 12:27:31 PST
Patch from Yi Shen added to qtwebkit-2.1.x (as a workaround for the QtMobility bug) with commit 429bbaa <http://gitorious.org/webkit/qtwebkit/commit/429bbaa>
Comment 9 Bruno Abinader (history only) 2012-01-20 07:52:58 PST
*** Bug 76007 has been marked as a duplicate of this bug. ***