Bug 75796 - Rename checkNodeSecurity and allowsAccessFromFrame to have sensible names
Summary: Rename checkNodeSecurity and allowsAccessFromFrame to have sensible names
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Adam Barth
URL:
Keywords:
Depends on:
Blocks: 75793
  Show dependency treegraph
 
Reported: 2012-01-08 02:30 PST by Adam Barth
Modified: 2012-02-02 19:24 PST (History)
6 users (show)

See Also:


Attachments
Patch (17.16 KB, patch)
2012-01-08 02:30 PST, Adam Barth
no flags Details | Formatted Diff | Diff
Patch for landing (18.49 KB, patch)
2012-01-08 14:41 PST, Adam Barth
no flags Details | Formatted Diff | Diff
Patch (20.63 KB, patch)
2012-02-02 15:38 PST, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2012-01-08 02:30:27 PST
Rename checkNodeSecurity and allowsAccessFromFrame to have sensible names
Comment 1 Adam Barth 2012-01-08 02:30:59 PST
Created attachment 121577 [details]
Patch
Comment 2 WebKit Review Bot 2012-01-08 02:55:11 PST
Comment on attachment 121577 [details]
Patch

Attachment 121577 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/11166171
Comment 3 Adam Barth 2012-01-08 14:41:29 PST
Created attachment 121590 [details]
Patch for landing
Comment 4 WebKit Review Bot 2012-01-08 15:15:59 PST
Comment on attachment 121590 [details]
Patch for landing

Clearing flags on attachment: 121590

Committed r104412: <http://trac.webkit.org/changeset/104412>
Comment 5 WebKit Review Bot 2012-01-08 15:16:03 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Darin Adler 2012-01-08 19:11:45 PST
A substantial improvement.

Wish I was around earlier today to comment on this. I would prefer shouldAllowAccessToNode rather than allowAccessToNode because the latter sounds like a verb phrase, and so seems like it could be a function that is used to “allow access” to a node.

We might also consider just calling these shouldAllowAccessTo and using overloading, since the types are distinct; on the other hand, leaving out the noun makes the names less clear, so we probably shouldn’t.
Comment 8 Adam Barth 2012-01-08 19:14:50 PST
Ok.  Will fix.
Comment 9 Adam Barth 2012-01-08 19:15:01 PST
Re-open to remind me to fix.
Comment 10 Adam Barth 2012-02-02 15:38:35 PST
Created attachment 125199 [details]
Patch
Comment 11 Eric Seidel (no email) 2012-02-02 15:40:52 PST
Comment on attachment 125199 [details]
Patch

OK.
Comment 12 WebKit Review Bot 2012-02-02 19:24:00 PST
Comment on attachment 125199 [details]
Patch

Clearing flags on attachment: 125199

Committed r106618: <http://trac.webkit.org/changeset/106618>
Comment 13 WebKit Review Bot 2012-02-02 19:24:05 PST
All reviewed patches have been landed.  Closing bug.