Bug 75624 - Web Inspector: Low Memory? Freeze/Crash when inspecting ImageData's CanvasPixelArray
Summary: Web Inspector: Low Memory? Freeze/Crash when inspecting ImageData's CanvasPix...
Status: RESOLVED DUPLICATE of bug 57320
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://fooo.fr/~vjeux/epita/raytracer...
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2012-01-05 08:08 PST by Chris H-C
Modified: 2012-01-05 08:29 PST (History)
12 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris H-C 2012-01-05 08:08:33 PST
When trying to expand a CanvasPixelArray data member of an ImageData object in the Scripts tab, the browser hogs memory and eventually freezes/crashes.

Issue present on at least BlackBerry Browser (BlackBerry PlayBook), Chromium 15 (Ubuntu), Chrome 17 (Windows XP).

The range of platforms suggests that it is javascript-engine independent (possible located in WebCore's bindings?) as Chrome uses v8 and the BlackBerry Browser uses JSC.

Reproduction steps:
1. Visit http://fooo.fr/~vjeux/epita/raytracer/raytracer.html#texturing
2. Inspect the Page
3. Navigate to Scripts
4. Apply breakpoint to trace.js:83 (Chrome seems to prefer :86)
5. Press "Ray Trace!"
6. When breakpoint is hit, add a watch expression for ctx.getImageData(0,0,this.width,this.height)
7. Expand the resultant ImageData
8. Attempt to expand 'data' the CanvasPixelArray member

Bug#67564 may or may not be interesting additional reading on this subject.
Comment 1 Pavel Feldman 2012-01-05 08:13:07 PST

*** This bug has been marked as a duplicate of bug 57320 ***