Bug 57320 - Web Inspector: Unsatisfying support for objects containing large arrays in Console
Summary: Web Inspector: Unsatisfying support for objects containing large arrays in Co...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 75624 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-29 02:42 PDT by Mikhail Naganov
Modified: 2016-02-04 19:51 PST (History)
18 users (show)

See Also:


Attachments
Repro page (408 bytes, text/html)
2011-03-29 02:42 PDT, Mikhail Naganov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Naganov 2011-03-29 02:42:31 PDT
Created attachment 87286 [details]
Repro page

Expanding an object with a huge array inside takes long time and can even crash renderer (observed in Chromium).

Consider the page attached -- it creates two objects: big1 and big2, that are almost identical. They both contain a huge array inside them, and in 'big1' this array doesn't have contents, but in 'big2' does.

If I evaluate 'big1' in console, and then expand the resulting object, I see its contents immediately. If I evaluate 'big2', and trying to expand it, I experience a delay, and with sufficiently large arrays (20M items), page can crash.

The results of both expansions are identical:

big1
  v Object
     > big_array: Array[20971520]
         f1: "aaa"
         f2: "bbb"
     > __proto__: Object

big2
  v Object
     > big_array: Array[20971520]
         f1: "aaa"
         f2: "bbb"
     > __proto__: Object

I'd expect a delay while trying to expand a 'big_array', but not when I'm expanding the container object.
Comment 1 Pavel Feldman 2012-01-05 08:13:07 PST
*** Bug 75624 has been marked as a duplicate of this bug. ***
Comment 2 Radar WebKit Bug Importer 2014-12-17 11:23:16 PST
<rdar://problem/19281532>
Comment 3 Brian Burg 2015-11-20 13:06:03 PST
Not an issue any more since we give up showing element previews when arrays are past a reasonable size.
Comment 4 Timothy Hatcher 2016-02-04 19:51:03 PST
<rdar://problem/13281722>