Bug 73311 - Web Inspector: introduce generic capabilities concept, migrate debugger domain to generic capabilities.
Summary: Web Inspector: introduce generic capabilities concept, migrate debugger domai...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Pavel Feldman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-29 05:35 PST by Pavel Feldman
Modified: 2011-11-29 12:57 PST (History)
11 users (show)

See Also:


Attachments
Patch (41.23 KB, patch)
2011-11-29 05:39 PST, Pavel Feldman
no flags Details | Formatted Diff | Diff
[Patch] for bots (41.21 KB, patch)
2011-11-29 06:05 PST, Pavel Feldman
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Feldman 2011-11-29 05:35:06 PST
This is necessary for getting rid of the "capability" part of the Preferences object.
Comment 1 Pavel Feldman 2011-11-29 05:39:28 PST
Created attachment 116950 [details]
Patch
Comment 2 WebKit Review Bot 2011-11-29 05:43:04 PST
Attachment 116950 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1

Source/WebCore/inspector/InspectorMetaAgent.cpp:47:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorMetaAgent.h:58:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 2 in 33 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Pavel Feldman 2011-11-29 06:05:34 PST
Created attachment 116955 [details]
[Patch] for bots
Comment 4 WebKit Review Bot 2011-11-29 06:08:10 PST
Attachment 116955 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/CMakeLists.txt', u'Source/W..." exit_code: 1

Source/WebCore/inspector/InspectorMetaAgent.cpp:47:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Source/WebCore/inspector/InspectorMetaAgent.h:58:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 2 in 33 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 5 Pavel Feldman 2011-11-29 06:43:28 PST
Committed r101367: <http://trac.webkit.org/changeset/101367>
Comment 6 Timothy Hatcher 2011-11-29 09:39:52 PST
Comment on attachment 116950 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=116950&action=review

> Source/WebCore/inspector/Inspector.json:44
> +        "domain": "Meta",

This is not a great name. Why can't these just be added to the Inspector domain? They fit there IMHO.
Comment 7 Pavel Feldman 2011-11-29 11:36:58 PST
(In reply to comment #6)
> (From update of attachment 116950 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=116950&action=review
> 
> > Source/WebCore/inspector/Inspector.json:44
> > +        "domain": "Meta",
> 
> This is not a great name. Why can't these just be added to the Inspector domain? They fit there IMHO.

It was my plan and I was cleaning up Inspector domain for that very reason. But there is a couple of methods that are still there, so I ended up creating a brand new agent. The idea is that this agent provides Metainformation on the agents, hence the name.

Btw, getting the https://bugs.webkit.org/show_bug.cgi?id=72506 reviewed for WebKit2 will make the legacy workers debugging support vanish and hence InspectorAgent clean.
Comment 8 Timothy Hatcher 2011-11-29 12:57:34 PST
(In reply to comment #7)
> (In reply to comment #6)
> > (From update of attachment 116950 [details] [details])
> > View in context: https://bugs.webkit.org/attachment.cgi?id=116950&action=review
> > 
> > > Source/WebCore/inspector/Inspector.json:44
> > > +        "domain": "Meta",
> > 
> > This is not a great name. Why can't these just be added to the Inspector domain? They fit there IMHO.
> 
> It was my plan and I was cleaning up Inspector domain for that very reason. But there is a couple of methods that are still there, so I ended up creating a brand new agent. The idea is that this agent provides Metainformation on the agents, hence the name.
> 
> Btw, getting the https://bugs.webkit.org/show_bug.cgi?id=72506 reviewed for WebKit2 will make the legacy workers debugging support vanish and hence InspectorAgent clean.

I see. The fact that the Inspector domain isn't empty shouldn't prevent adding these and removing the other methods from the Inspector domain once they can be removed. So I don't buy the argument that Meta needs to exists for that reason.