These functions are just thin wrappers around classList now. We should use classList cirectly instead of these functions.
I did TreeOutline in r101313 because I had done it internally on a copy we use in Safari and I upstreamed our changes.
We should do the rest of the Inspector next!
There was a comment in:
<http://webkit.org/b/55758> Web Inspector: Make use of element.classList in utilities.js
> Bug 56096 fixes the first item, and we have agreed with pfeldman that the
> add/remove/hasStyleClass improve readability, so the classList methods will
> not be inlined. We have reached our primary goal of getting rid of regex-based
> operations and the className property modification (which is slow).
I think reducing out own wrappers is a good idea, especially if they are so thin as these are.
We should also remove Function.prototype.bind, which is native in JSC at least not sure about V8.
reducing our own*