Bug 72362 - [Qt4] tst_QDeclarativeWebView assert
Summary: [Qt4] tst_QDeclarativeWebView assert
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 38654 79668 QtWebkit23
  Show dependency treegraph
 
Reported: 2011-11-15 00:57 PST by Ádám Kallai
Modified: 2012-11-26 12:18 PST (History)
5 users (show)

See Also:


Attachments
gdb backtrace for tst_QDeclarativeWebView (6.05 KB, text/plain)
2011-11-15 00:57 PST, Ádám Kallai
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ádám Kallai 2011-11-15 00:57:38 PST
Created attachment 115117 [details]
gdb backtrace for tst_QDeclarativeWebView

gdb backtrace attached
Comment 1 Michael Brüning 2012-05-16 07:33:40 PDT
Looks as if this is caused by setting the offline web app cache path both in initTestCase and in some test cases themselves... 

Will have a look.
Comment 2 Michael Brüning 2012-05-16 08:07:07 PDT
Okay, this can only be tested with Qt 4.8 and a WebKit version that builds with it. I don't have a build env for that ready, but my assumption is that the calls to QWebSettings::enablePersistentStorage(tmpDir()); should be removed from the test cases as they will trigger the assert that caused the crash.
Comment 3 Csaba Osztrogonác 2012-11-14 04:46:55 PST
Are we still interested in fixing Qt 4.8 related bugs in WebKit 
trunk for QtWebKit 2.3 branch?
Comment 4 Allan Sandfeld Jensen 2012-11-14 06:48:33 PST
I think that test has been removed in trunk, and is only present in qtwebkit2.3?
Comment 5 Csaba Osztrogonác 2012-11-14 06:50:31 PST
Good point ... the question is now if we wan't to track a 
QtWebKit 2.3 only failure here or not?
Comment 6 Allan Sandfeld Jensen 2012-11-14 07:44:28 PST
We have a tracker bug for that
Comment 7 Allan Sandfeld Jensen 2012-11-26 12:18:49 PST
The issue was fixed two weeks ago in 15f943b89cba18a9a758bac32137d5255a9973d3

The problem was that QDeclarativeWebView was not build at all due to a mistake in the qmake file.