Bug 7139 - Drop support for <isindex>
Summary: Drop support for <isindex>
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: PC Linux
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-02-07 22:20 PST by Ian 'Hixie' Hickson
Modified: 2016-09-13 08:04 PDT (History)
19 users (show)

See Also:


Attachments
Patch (283.81 KB, patch)
2016-09-12 21:03 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 'Hixie' Hickson 2006-02-07 22:20:00 PST
According to my study of one billion Web pages, less than 0.0013% of pages use the <isindex> element. In fact, so few pages use it that it didn't appear on my top 1000 most-used elements list, meaning it was used less than <side_ads>, <preform>, <titolo>, <bdbereich>, <org>, <cunet>, <l1>, <hot:trolley>, and numerous other bogus elements.

<isindex> has been a pain (see e.g. bug 4574 or bug 4828), and Safari's support for it differs from Mozilla's, IE's, and Opera's.

I would like to drop support for parsing <isindex> specially in HTML5. If it turns out that <isindex> _is_ in fact used, then we'll find out about it soon and can change the HTML5 spec so that it is clear how it should be implemented.
Comment 1 Ian 'Hixie' Hickson 2006-02-07 22:21:16 PST
(m326369, o195531)
Comment 2 Anne van Kesteren 2008-01-28 16:08:12 PST
HTML5 was changed by the way to support <isindex> in the parser.
Comment 3 Robert Blaut 2008-02-11 03:30:15 PST
(In reply to comment #2)
> HTML5 was changed by the way to support <isindex> in the parser.
> 

So shouldn't the bug to be resolved as WONTFIX?
Comment 4 David Kilzer (:ddkilzer) 2008-02-23 13:45:22 PST
(In reply to comment #3)
> (In reply to comment #2)
> > HTML5 was changed by the way to support <isindex> in the parser.
> So shouldn't the bug to be resolved as WONTFIX?

Yes.

Comment 5 David Kilzer (:ddkilzer) 2008-04-10 13:25:29 PDT
(In reply to comment #0)
> <isindex> has been a pain (see e.g. bug 4574 or bug 4828), and Safari's support
> for it differs from Mozilla's, IE's, and Opera's.

And Bug 18415.

Comment 6 Theresa O'Connor 2015-04-22 12:28:19 PDT
Since we last looked at this, Chrome and IE have both said they will drop support for this tag.

Blink thread: https://groups.google.com/a/chromium.org/forum/#!topic/blink-dev/14q_I06gwg8

I can't find a citation for isindex being dropped in Project Spartan, but Travis from MSFT confirmed this in a conversation.
Comment 7 Domenic Denicola 2016-04-21 11:05:05 PDT
Right now we're at 2 vs. 2 rendering engines with regard to isindex support. Is WebKit interested in following along and removing it? https://github.com/whatwg/html/issues/1088
Comment 8 Simon Pieters 2016-09-12 05:50:46 PDT
It has been removed from the spec.

Tests added to web-platform-tests in

https://github.com/w3c/web-platform-tests/pull/3684

and html5lib-tests in

https://github.com/html5lib/html5lib-tests/pull/74
Comment 9 Chris Dumez 2016-09-12 19:01:38 PDT
Given that this was dropped from the HTML spec, Chrome and Edge, I think we should at least try to drop <isindex>.
Comment 10 Chris Dumez 2016-09-12 21:03:09 PDT
Created attachment 288667 [details]
Patch
Comment 11 Chris Dumez 2016-09-12 21:05:37 PDT
Corresponding Mozilla bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1266495
Comment 12 WebKit Commit Bot 2016-09-13 08:04:52 PDT
Comment on attachment 288667 [details]
Patch

Clearing flags on attachment: 288667

Committed r205858: <http://trac.webkit.org/changeset/205858>
Comment 13 WebKit Commit Bot 2016-09-13 08:04:58 PDT
All reviewed patches have been landed.  Closing bug.