Bug 7023 - Searching in text areas
Summary: Searching in text areas
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 420+
Hardware: Mac OS X 10.4
: P2 Enhancement
Assignee: mitz
URL:
Keywords: InRadar
: 14592 15155 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-02-02 03:31 PST by Daniele Metilli
Modified: 2009-10-29 14:15 PDT (History)
9 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele Metilli 2006-02-02 03:31:22 PST
This is not a bug, it's a feature request: would it be possible to implement searching inside text areas? It would be useful. Thank you.
Comment 1 John Sullivan 2006-02-02 08:12:48 PST
This is already in Radar as <rdar://problem/3099526>. That bug requests searching in form text fields as well as textareas. This should become significantly more straightforward to implement when textareas no longer use NSView for their implementation.
Comment 2 Naofumi Kagami 2007-09-07 05:23:10 PDT
*** Bug 15155 has been marked as a duplicate of this bug. ***
Comment 3 Drew 2008-02-13 08:35:36 PST
This still doesn't work even after moving away from NSView (unless I missed something and the new resizable text areas are still using NSView). This is a big usability issue for web apps that allow editing but don't use WYSIWYG editors (which seem to be a workaround for this bug).
Comment 4 Robert Blaut 2008-02-18 13:22:30 PST
*** Bug 14592 has been marked as a duplicate of this bug. ***
Comment 5 mitz 2008-06-26 20:26:46 PDT
Fixed in <http://trac.webkit.org/changeset/34822>.
Comment 6 Finnur Thorarinsson 2009-10-29 14:15:15 PDT
I should mention that the fix for this seems to have caused a regression...
https://bugs.webkit.org/show_bug.cgi?id=25868