Bug 69615 - [Qt] http/tests/multipart/load-last-non-html-frame.php is failing
: [Qt] http/tests/multipart/load-last-non-html-frame.php is failing
Status: RESOLVED DUPLICATE of bug 47060
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: Unspecified Linux
: P2 Normal
Assigned To: Nobody
: Qt, QtTriaged
Depends on: 47059 69449
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-07 03:54 PDT by Zoltan Horvath
Modified: 2011-10-11 10:24 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Horvath 2011-10-07 03:54:36 PDT
http/tests/multipart/load-last-non-html-frame.php is failing on Qt Linux Release

DIFF
--- /ramdisk/qt-linux-release/build/layout-test-results/http/tests/multipart/load-last-non-html-frame-expected.txt 
+++ /ramdisk/qt-linux-release/build/layout-test-results/http/tests/multipart/load-last-non-html-frame-actual.txt 
@@ -1,3 +1,12 @@
-This test passes if the last multipart frame is displayed.
-PASS
-                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        
+layer at (0,0) size 800x600
+  RenderView at (0,0) size 800x600
+layer at (0,0) size 800x600
+  RenderBlock {HTML} at (0,0) size 800x600
+    RenderBody {BODY} at (8,8) size 784x584
+      RenderText {#text} at (0,0) size 756x44
+        text run at (0,0) width 207: "--asdf Content-type: text/plain "
+        text run at (207,0) width 413: "This test passes if the last multipart frame is displayed. FAIL "
+        text run at (620,0) width 136: "--asdf Content-type:"
+        text run at (0,22) width 67: "text/plain "
+        text run at (67,22) width 414: "This test passes if the last multipart frame is displayed. PASS "
+        text run at (481,22) width 48: "--asdf--"

The  test was introduced in: http://trac.webkit.org/changeset/96856 (bug #69449)
Comment 1 Zoltan Horvath 2011-10-07 04:12:07 PDT
Skipped in http://trac.webkit.org/changeset/96928.
Comment 2 Zoltan Arvai 2011-10-11 02:34:09 PDT
Qtwebkit has no multipart support:
https://bugs.webkit.org/show_bug.cgi?id=47059

Qt 4.8 will support it:
http://developer.qt.nokia.com/forums/viewthread/6354
Comment 3 Csaba Osztrogonác 2011-10-11 03:07:37 PDT

*** This bug has been marked as a duplicate of bug 47060 ***
Comment 4 Robert Hogan 2011-10-11 10:24:47 PDT
(In reply to comment #2)
> Qt 4.8 will support it:
> http://developer.qt.nokia.com/forums/viewthread/6354

As far as I know only *sending* multipart messages is supported in 4.8, receiving them is still not supported and should probably sit in QtWebKit anyway.