Bug 68931 - nrwt: newly generated results are put in cross-platform directory
Summary: nrwt: newly generated results are put in cross-platform directory
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords:
Depends on:
Blocks: 64491
  Show dependency treegraph
 
Reported: 2011-09-27 13:48 PDT by Ryosuke Niwa
Modified: 2011-10-20 20:35 PDT (History)
8 users (show)

See Also:


Attachments
fixes the bug (6.61 KB, patch)
2011-10-20 17:48 PDT, Ryosuke Niwa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2011-09-27 13:48:03 PDT
old-run-webkit-tests put newly generated results in right directory (e.g. platform/mac, platform/win. etc...) new-run-webkit-tests appears to put new results in wherever tests are, which is very annoying for pixel tests as contributors need to manually move them all to platform/X/
Comment 1 Ryosuke Niwa 2011-10-20 17:48:26 PDT
Created attachment 111882 [details]
fixes the bug
Comment 2 Adam Barth 2011-10-20 17:49:56 PDT
Comment on attachment 111882 [details]
fixes the bug

View in context: https://bugs.webkit.org/attachment.cgi?id=111882&action=review

> Tools/Scripts/webkitpy/layout_tests/controllers/single_test_runner.py:145
> +    _render_tree_dump_pattern = re.compile(r"^layer at \(\d+,\d+\) size \d+x\d+\n")

hum...
Comment 3 Ryosuke Niwa 2011-10-20 17:57:50 PDT
(In reply to comment #2)
> (From update of attachment 111882 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=111882&action=review
> 
> > Tools/Scripts/webkitpy/layout_tests/controllers/single_test_runner.py:145
> > +    _render_tree_dump_pattern = re.compile(r"^layer at \(\d+,\d+\) size \d+x\d+\n")
> 
> hum...

Don't like it?
Comment 4 Adam Barth 2011-10-20 17:59:00 PDT
Looks like a hack, right?
Comment 5 Ryosuke Niwa 2011-10-20 18:03:16 PDT
(In reply to comment #4)
> Looks like a hack, right?

Not really. I'm detecting whether the output looks like render tree dump or not. Since there is currently no way for us to know whether a test prints render tree dump or not, I don't think we can do better. orwt uses a similar trick in isTextOnlyTest.
Comment 6 Adam Barth 2011-10-20 18:08:19 PDT
Another approach might be to have DRT return a Content-Type header that says whether it is a text dump or a render tree dump.
Comment 7 Ryosuke Niwa 2011-10-20 18:48:20 PDT
(In reply to comment #6)
> Another approach might be to have DRT return a Content-Type header that says whether it is a text dump or a render tree dump.

Yeah, that'll be cleaner and will be a nice follow up to do. This bug is about the regression that nrwt doesn't behave like orwt and this patch fixes exactly that.
Comment 8 WebKit Review Bot 2011-10-20 20:34:59 PDT
Comment on attachment 111882 [details]
fixes the bug

Clearing flags on attachment: 111882

Committed r98062: <http://trac.webkit.org/changeset/98062>
Comment 9 WebKit Review Bot 2011-10-20 20:35:04 PDT
All reviewed patches have been landed.  Closing bug.