Bug 67709 - Implement double tap detection in GestureRecognizerChromium
: Implement double tap detection in GestureRecognizerChromium
Status: RESOLVED FIXED
: WebKit
New Bugs
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Normal
Assigned To:
:
:
: 67645
:
  Show dependency treegraph
 
Reported: 2011-09-07 08:13 PST by
Modified: 2011-09-08 14:10 PST (History)


Attachments
Patch (14.96 KB, patch)
2011-09-07 08:14 PST, Varun Jain
no flags Review Patch | Details | Formatted Diff | Diff
Patch (14.78 KB, patch)
2011-09-07 12:49 PST, Varun Jain
no flags Review Patch | Details | Formatted Diff | Diff
Patch (15.42 KB, patch)
2011-09-07 12:57 PST, Varun Jain
no flags Review Patch | Details | Formatted Diff | Diff
Patch (15.57 KB, patch)
2011-09-08 11:57 PST, Varun Jain
no flags Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-09-07 08:13:56 PST
Implement double tap detection in GestureRecognizerChromium
------- Comment #1 From 2011-09-07 08:14:41 PST -------
Created an attachment (id=106585) [details]
Patch
------- Comment #2 From 2011-09-07 08:15:54 PST -------
*** Bug 67708 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2011-09-07 11:16:47 PST -------
(From update of attachment 106585 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=106585&action=review

LGTM. But you should update the patch for the intended order of committing.

> Source/WebCore/platform/PlatformGestureEvent.h:42
> +        DoubleTapType,

this cl will not merge clean with the other one. In particular, the unit tests will fail. You should pick an order of committing and write one patch as a dependency of the other
------- Comment #4 From 2011-09-07 12:49:13 PST -------
Created an attachment (id=106621) [details]
Patch
------- Comment #5 From 2011-09-07 12:55:21 PST -------
(In reply to comment #3)
> (From update of attachment 106585 [details] [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=106585&action=review
> 
> LGTM. But you should update the patch for the intended order of committing.
> 
> > Source/WebCore/platform/PlatformGestureEvent.h:42
> > +        DoubleTapType,
> 
> this cl will not merge clean with the other one. In particular, the unit tests will fail. You should pick an order of committing and write one patch as a dependency of the other

Merged the other CL.
------- Comment #6 From 2011-09-07 12:57:41 PST -------
Created an attachment (id=106622) [details]
Patch
------- Comment #7 From 2011-09-07 12:59:22 PST -------
Missed the Changelog in previous patch. Uploaded new one..  PTAL
------- Comment #8 From 2011-09-08 11:57:05 PST -------
Created an attachment (id=106771) [details]
Patch
------- Comment #9 From 2011-09-08 14:10:50 PST -------
(From update of attachment 106771 [details])
Clearing flags on attachment: 106771

Committed r94797: <http://trac.webkit.org/changeset/94797>
------- Comment #10 From 2011-09-08 14:10:54 PST -------
All reviewed patches have been landed.  Closing bug.