Bug 67603 - Hidden elements should not have focus.
Summary: Hidden elements should not have focus.
Status: RESOLVED DUPLICATE of bug 40338
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-05 07:42 PDT by Vineet Chaudhary (vineetc)
Modified: 2011-09-05 13:50 PDT (History)
2 users (show)

See Also:


Attachments
Test page (611 bytes, text/html)
2011-09-05 07:42 PDT, Vineet Chaudhary (vineetc)
no flags Details
Patch (1.44 KB, patch)
2011-09-05 08:26 PDT, Vineet Chaudhary (vineetc)
webkit.review.bot: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vineet Chaudhary (vineetc) 2011-09-05 07:42:43 PDT
Created attachment 106337 [details]
Test page

Even after applying "display:none" property on focused element, it still has focus though its renderers are dropped.

To  reproduce the issue please find the attached test page.
After div element gets hidden press enter key. 

Expected : It should not redirect to google.com
Actual   : It redirects to google.com
Comment 1 Vineet Chaudhary (vineetc) 2011-09-05 08:26:12 PDT
Created attachment 106340 [details]
Patch
Comment 2 WebKit Review Bot 2011-09-05 09:51:06 PDT
Comment on attachment 106340 [details]
Patch

Attachment 106340 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/9595298

New failing tests:
fast/events/tab-imagemap.html
scrollbars/disabled-scrollbar.html
fast/events/mouse-focus-imagemap.html
fast/css-generated-content/001.html
scrollbars/listbox-scrollbar-combinations.html
scrollbars/overflow-scrollbar-combinations.html
Comment 3 Alexey Proskuryakov 2011-09-05 13:49:56 PDT

*** This bug has been marked as a duplicate of bug 40338 ***
Comment 4 Alexey Proskuryakov 2011-09-05 13:50:23 PDT
Comment on attachment 106340 [details]
Patch

Clearing r? because of failing tests, and because of duplicate status.