Bug 67580 - POTFILES.in/.skip need updates for translators
: POTFILES.in/.skip need updates for translators
Status: RESOLVED FIXED
: WebKit
WebKit Gtk
: 528+ (Nightly build)
: Unspecified Unspecified
: P2 Minor
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2011-09-04 16:37 PST by
Modified: 2012-10-27 12:22 PST (History)


Attachments
Patch (6.97 KB, patch)
2012-10-20 23:44 PST, Martin Robinson
xan.lopez: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-09-04 16:37:22 PST
http://l10n.gnome.org/module/webkit/ lists quite some issues with /po/POTFILES.in/.skip that block creating an up-to-date translation template and hence create an unneeded burden for translation contributors.
------- Comment #1 From 2012-03-22 14:44:37 PST -------
This really does need to be addressed.
------- Comment #2 From 2012-08-30 19:29:38 PST -------
This ticket is blocking for the following:

https://bugzilla.gnome.org/show_bug.cgi?id=610165
https://bugzilla.gnome.org/show_bug.cgi?id=610164
https://bugzilla.gnome.org/show_bug.cgi?id=610163
https://bugzilla.gnome.org/show_bug.cgi?id=610162
https://bugzilla.gnome.org/show_bug.cgi?id=610161
https://bugzilla.gnome.org/show_bug.cgi?id=610160
https://bugzilla.gnome.org/show_bug.cgi?id=610159
https://bugzilla.gnome.org/show_bug.cgi?id=610158
https://bugzilla.gnome.org/show_bug.cgi?id=610155
https://bugzilla.gnome.org/show_bug.cgi?id=610153
https://bugzilla.gnome.org/show_bug.cgi?id=610151
https://bugzilla.gnome.org/show_bug.cgi?id=610150
https://bugzilla.gnome.org/show_bug.cgi?id=610149
https://bugzilla.gnome.org/show_bug.cgi?id=610147
https://bugzilla.gnome.org/show_bug.cgi?id=610146
https://bugzilla.gnome.org/show_bug.cgi?id=610145
https://bugzilla.gnome.org/show_bug.cgi?id=610144
https://bugzilla.gnome.org/show_bug.cgi?id=610142
https://bugzilla.gnome.org/show_bug.cgi?id=610139
https://bugzilla.gnome.org/show_bug.cgi?id=610138
https://bugzilla.gnome.org/show_bug.cgi?id=610135
https://bugzilla.gnome.org/show_bug.cgi?id=610129
https://bugzilla.gnome.org/show_bug.cgi?id=610128
https://bugzilla.gnome.org/show_bug.cgi?id=610125
https://bugzilla.gnome.org/show_bug.cgi?id=610120
https://bugzilla.gnome.org/show_bug.cgi?id=610118
https://bugzilla.gnome.org/show_bug.cgi?id=610115
https://bugzilla.gnome.org/show_bug.cgi?id=610113
https://bugzilla.gnome.org/show_bug.cgi?id=610112
https://bugzilla.gnome.org/show_bug.cgi?id=610111
https://bugzilla.gnome.org/show_bug.cgi?id=610110
https://bugzilla.gnome.org/show_bug.cgi?id=610109
https://bugzilla.gnome.org/show_bug.cgi?id=610106
https://bugzilla.gnome.org/show_bug.cgi?id=610103
https://bugzilla.gnome.org/show_bug.cgi?id=610102
https://bugzilla.gnome.org/show_bug.cgi?id=610095
https://bugzilla.gnome.org/show_bug.cgi?id=610094
------- Comment #3 From 2012-10-14 12:13:49 PST -------
So who do I need to talk to here? 
Currently this makes the Epiphany browser on GNOME look rather untranslated.
------- Comment #4 From 2012-10-14 12:24:42 PST -------
I think this bug is blocked by 

https://bugs.webkit.org/show_bug.cgi?id=45321

I've been trying to get something done about it, with no success so far.

I did get Martin Robinson (webkitgtk+) talking to Claude Paroz (gnome-18n) two weeks ago , to see about a hackish fix, like the symlink one mentioned in that bug, but that conversation has gone quiet since.
------- Comment #5 From 2012-10-20 21:13:03 PST -------
The first step is to fix the list of files in POTFILES (and move it to POTFILES.in for the sake of intltool). The second step is to fix intltoool-update -m, which requires changes to intltools. I think that should be enough to get Damned Lies working. If not, it should get us closer.
------- Comment #6 From 2012-10-20 23:44:31 PST -------
Created an attachment (id=169787) [details]
Patch
------- Comment #7 From 2012-10-22 02:52:52 PST -------
(From update of attachment 169787 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=169787&action=review

> Source/WebKit/gtk/po/GNUmakefile.am:72
> +$(DOMAIN).pot-update: $(POTFILES) Source/WebKit/gtk/po/POTFILES

Don't we want top_builddir here? Or does it have to be absolutely nothing.

> Source/WebKit/gtk/po/GNUmakefile.am:87
> +	        --files-from=Source/WebKit/gtk/po/POTFILES \

Same question.

> Source/WebKit/gtk/po/GNUmakefile.am:100
> +	        --files-from=Source/WebKit/gtk/po/POTFILES \

And same.
------- Comment #8 From 2012-10-22 09:26:17 PST -------
(In reply to comment #7)
> (From update of attachment 169787 [details] [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=169787&action=review
> 
> > Source/WebKit/gtk/po/GNUmakefile.am:72
> > +$(DOMAIN).pot-update: $(POTFILES) Source/WebKit/gtk/po/POTFILES
> 
> Don't we want top_builddir here? Or does it have to be absolutely nothing.

The build directory will always be the current directory, I believe. We make that assumption in other places, so I think we're safe omitting $(top_builddir).
------- Comment #9 From 2012-10-22 15:18:49 PST -------
(From update of attachment 169787 [details])
Still seems safer to put the variable there; it works now but we might change the build system somehow and it would stop. Good practice to make assumptions explicit! Anyway, r+, you can change before landing.
------- Comment #10 From 2012-10-23 18:48:28 PST -------
Committed r132289: <http://trac.webkit.org/changeset/132289>
------- Comment #11 From 2012-10-23 23:51:35 PST -------
*** Bug 45321 has been marked as a duplicate of this bug. ***
------- Comment #12 From 2012-10-27 12:22:23 PST -------
*** Bug 81969 has been marked as a duplicate of this bug. ***