Bug 45321 - Current l10n infrastructure not completely intltool compliant
Summary: Current l10n infrastructure not completely intltool compliant
Status: RESOLVED DUPLICATE of bug 67580
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 66764 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-07 14:13 PDT by claude
Modified: 2012-10-23 23:51 PDT (History)
8 users (show)

See Also:


Attachments
webkit-gtk-intltoolize.patch (17.74 KB, patch)
2011-08-09 08:41 PDT, Priit Laes (IRC: plaes)
gns: commit-queue-
Details | Formatted Diff | Diff
webkit-intltool.patch (15.96 KB, patch)
2012-02-06 10:41 PST, Priit Laes (IRC: plaes)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description claude 2010-09-07 14:13:20 PDT
The /WebKit/gtk/po is currently not intltool compliant. The POTFILES must be named POTFILES.in (and you can also add an empty POTFILES.skip, in case you want to blacklist some files). Here is a working POTFILES.in:

# List of source files which contain translatable strings.
WebCoreSupport/ChromeClientGtk.cpp
WebCoreSupport/ContextMenuClientGtk.cpp
WebCoreSupport/FrameLoaderClientGtk.cpp
WebCoreSupport/FullscreenVideoController.cpp
webkit/webkitdownload.cpp
webkit/webkithittestresult.cpp
webkit/webkitnetworkrequest.cpp
webkit/webkitnetworkresponse.cpp
webkit/webkitsecurityorigin.cpp
webkit/webkitsoupauthdialog.c
webkit/webkitwebdatabase.cpp
webkit/webkitwebframe.cpp
webkit/webkitwebhistoryitem.cpp
webkit/webkitwebinspector.cpp
webkit/webkitwebnavigationaction.cpp
webkit/webkitwebresource.cpp
webkit/webkitwebsettings.cpp
webkit/webkitwebview.cpp
../../WebCore/platform/gtk/LocalizedStringsGtk.cpp

After those changes, we may be able to generate stats again on http://l10n.gnome.org/module/webkit/
Comment 1 Priit Laes (IRC: plaes) 2011-08-09 08:41:42 PDT
Created attachment 103364 [details]
webkit-gtk-intltoolize.patch

This is a bit hacky version of adding intltool support for l10n infrastructure.

Why hacky? Because currently intltool only support po-directories on top-level of $srcdir. :(
Comment 2 Gustavo Noronha (kov) 2011-08-09 08:49:42 PDT
Comment on attachment 103364 [details]
webkit-gtk-intltoolize.patch

Attachment 103364 [details] did not pass gtk-ews (gtk):
Output: http://queues.webkit.org/results/9336287
Comment 3 Martin Robinson 2011-09-12 15:51:24 PDT
Alex, you're looked at the intltool stuff before. Maybe you could take a look at this patch?
Comment 4 Eric Seidel (no email) 2012-01-10 18:45:31 PST
Curious what the status here is and if it should still be up for review 4 months later?
Comment 5 Gustavo Noronha (kov) 2012-02-06 09:59:43 PST
*** Bug 66764 has been marked as a duplicate of this bug. ***
Comment 6 Priit Laes (IRC: plaes) 2012-02-06 10:41:12 PST
Created attachment 125667 [details]
webkit-intltool.patch

Hack warning: it works by 'faking' the path for intltool files directory by creating a symlink from original 'po' directory to to $topdir/po.

Although it's a hack it seems that everything went better than expected, because po-files get automatically build and installed and even `make dist` seems to work.
Comment 7 claude 2012-10-23 23:51:35 PDT
Seems to have been solved in #67580

*** This bug has been marked as a duplicate of bug 67580 ***