Bug 66314 - Web Inspector: Feature request: "Add Watch" functionality
Summary: Web Inspector: Feature request: "Add Watch" functionality
Status: RESOLVED DUPLICATE of bug 128785
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.7
: P3 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-16 09:59 PDT by Jeremy Kahn
Modified: 2014-12-15 21:06 PST (History)
11 users (show)

See Also:


Attachments
This is what the feature in Firebug looks like. (61.84 KB, image/png)
2011-08-16 10:05 PDT, Jeremy Kahn
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Kahn 2011-08-16 09:59:12 PDT
Overview:  Firebug has an "Add Watch" function that is extremely helpful.  In Firebug, when you are inspecting JavaScript, you can highlight a variable, contextual click, and select "Add Watch."  All this does is save developers the trouble of copy/pasting the text of the variable and adding it to the Watch column.  It's a time saver.

I would like to request that similar functionality be implemented into WebKit.

(Side note:  This is my first feature request.  If I am submitting it incorrectly, please let me know.)
Comment 1 Jeremy Kahn 2011-08-16 10:05:03 PDT
Created attachment 104061 [details]
This is what the feature in Firebug looks like.
Comment 2 Brian Burg 2014-12-15 21:05:42 PST

*** This bug has been marked as a duplicate of bug 128795 ***
Comment 3 Brian Burg 2014-12-15 21:06:02 PST

*** This bug has been marked as a duplicate of bug 128785 ***