Bug 64347 - NRWT should reopen/reload the results page after the run finished
Summary: NRWT should reopen/reload the results page after the run finished
Status: RESOLVED DUPLICATE of bug 64346
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 34984
  Show dependency treegraph
 
Reported: 2011-07-12 00:50 PDT by Nikolas Zimmermann
Modified: 2011-07-12 02:28 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolas Zimmermann 2011-07-12 00:50:49 PDT
NRWT should reopen/reload the results page after the run finished.
Now this bug hit me hard :-) I usually debug like this:
1. write code; 2. run-webkit-tests --tolerance 0 -p svg 3. look at results page -> fix code, recompile, rerun tests, look at page.
ORWT used to open a new Safari every time (with run-safari, not the system Safari, see bug 64346). NRWT does NOT, so I've stared at old results for a hour yesterday, wondering why even reverting my patch didn't help.
I must admit: I didn't look close at the nrwt output, but only at the results page in Safari, as I thought it would have been reloaded.....

Can we restore the old behaviour and just launch a new safari upon test run completion?
Comment 1 Eric Seidel (no email) 2011-07-12 00:51:53 PDT
I suspect we would just fix this by fixing bug 64346.
Comment 2 Eric Seidel (no email) 2011-07-12 02:28:16 PDT

*** This bug has been marked as a duplicate of bug 64346 ***
Comment 3 Eric Seidel (no email) 2011-07-12 02:28:38 PDT
Please re-open if I've incorrectly duped these.  Posting a patch on the other bug momentarily.