Bug 64279 - [Qt][Mac]2 jscore tests fail, 1-2 layout tests crash intermittently
Summary: [Qt][Mac]2 jscore tests fail, 1-2 layout tests crash intermittently
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Critical
Assignee: Nobody
URL:
Keywords: Qt, QtTriaged
Depends on:
Blocks: 64181 67920 79668
  Show dependency treegraph
 
Reported: 2011-07-11 07:05 PDT by Csaba Osztrogonác
Modified: 2012-10-08 23:32 PDT (History)
7 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2011-07-11 07:05:40 PDT
http://build.webkit.sed.hu/builders/Qt%20SnowLeopard%20Intel%20Release/builds/3028/steps/jscore-test/logs/stdio

sh: line 1: 13433 Segmentation fault      "/buildbot/snowleopard-qt-release/snowleopard-qt-intel-release/build/WebKitBuild/Release/JavaScriptCore/jsc" -s -f ./js1_5/shell.js -f ./js1_5/Regress/regress-152646.js 2>&1
sh: line 1: 13453 Segmentation fault      "/buildbot/snowleopard-qt-release/snowleopard-qt-intel-release/build/WebKitBuild/Release/JavaScriptCore/jsc" -s -f ./js1_5/shell.js -f ./js1_5/Regress/regress-192414.js 2>&1

** Danger, Will Robinson! Danger! The following failures have been introduced:
	js1_5/Regress/regress-152646.js
	js1_5/Regress/regress-192414.js

I only reported this bug, I can't test QtWebKit on a Mac and I can't fix JSC.
I cc-ed folks who may be interested in fixing it and be able to do it.
Comment 1 Gavin Barraclough 2011-07-11 10:37:35 PDT
This patch reverted the changes landed in r90601 & r90602, which should not have changed any jsc test results.

 * Did you see these tests start working between r90600 to r90602?

 * Can you repro these tests working under r90672 and failing on r90673?
Comment 2 Csaba Osztrogonác 2011-07-28 06:39:40 PDT
It seems jsc tests now pass, but there are many layout tests crash intermittently:
- ietestcenter/Javascript/15.2.3.11-1.html 
- fast/css/first-letter-anonymous-block-crash.html 
- fast/dom/attribute-namespaces.xhtml 
- fast/dynamic/insertAdjacentText.html 
- svg/custom/svg-parse-overflow-5.html 
- fast/css/dashboard-regions-attr-crash.html
Comment 3 Csaba Osztrogonác 2011-09-07 03:53:30 PDT
Layout tests still crash intermittently on the Qt-Mac buildbots:

- trunk bot: http://build.webkit.sed.hu/builders/Qt%20SnowLeopard%20Intel%20Release
- 2.2 branch bot: http://build.webkit.sed.hu/builders/QtWebKit2.2-branch%20SnowLeopard%20Intel%20Release

It seems it is a serious JavaScriptCore bug, but I can't help to fix it, because I don't have QtWebKit build environment on Mac and I'm not a JSC expert. But it should block 2.2 release, because it would be a shame if we would release QtWebKit 2.2 with this annoying JSC bug.
Comment 4 Csaba Osztrogonác 2011-09-07 03:54:44 PDT
cc-ing Alexis the Mac-QtWebKit hacker
Comment 5 Ademar Reis 2011-09-09 07:16:33 PDT
(In reply to comment #3)
> Layout tests still crash intermittently on the Qt-Mac buildbots:
> 
> - trunk bot: http://build.webkit.sed.hu/builders/Qt%20SnowLeopard%20Intel%20Release
> - 2.2 branch bot: http://build.webkit.sed.hu/builders/QtWebKit2.2-branch%20SnowLeopard%20Intel%20Release
> 
> It seems it is a serious JavaScriptCore bug, but I can't help to fix it, because I don't have QtWebKit build environment on Mac and I'm not a JSC expert. But it should block 2.2 release, because it would be a shame if we would release QtWebKit 2.2 with this annoying JSC bug.

r90673 is not present in QtWebKit-2.2 and the mac-buildbot for 2.2 has been unstable for a while... Is there a correlation between the failures from there and this bug? Below are the crashes from the 5 builds:

#163:
fast/css/button-height.html
fast/profiler/multiple-anonymous-functions-called-from-the-same-function.html
svg/dom/SVGAnimatedBoolean.html

#164:
sputnik/Conformance/07_Lexical_Conventions/7.8_Literals/7.8.5_Regular_Expression_Literals/S7.8.5_A2.2_T2.html
svg/dom/svglist-exception-on-out-bounds-error.html

#165:
fast/gradients/css3-gradient-parsing.html
fast/js/exception-thrown-from-eval-inside-closure.html
sputnik/Conformance/07_Lexical_Conventions/7.9_Automatic_Semicolon_Insertion/S7.9_A10_T7.html

#166:
fast/frames/flattening/iframe-flattening-nested.html
fast/profiler/start-and-stop-profiler-multiple-times.html

#167:
fast/dom/array-special-accessors-should-ignore-items.html
Comment 6 Csaba Osztrogonác 2011-09-09 07:30:15 PDT
I don't know what caused these crashes. Maybe r90673 is absolutely innocent. I noticed crashes from this revision. But debugging without crash log and without QtWebKit build on Mac is absolutely impossible. Somebody who has QtWebKit build on a Mac should debug this bug. I don't think if the bot is unstable, but there is a serious JSC bug in QtWebKit on Mac. But I can't confirm it without a local build.
Comment 7 Ademar Reis 2011-09-09 10:40:50 PDT
Since we're not sure if this bug indeed affects qtwebkit-2.2, I'm removing it from the blockers list. If we get confirmation, we'll add it back.

BTW, the build passed just now and the 2.2 mac bot is now green.
Comment 8 Csaba Osztrogonác 2011-09-09 10:50:36 PDT
(In reply to comment #7)
> Since we're not sure if this bug indeed affects qtwebkit-2.2, I'm removing it from the blockers list. If we get confirmation, we'll add it back.
> 
> BTW, the build passed just now and the 2.2 mac bot is now green.

And who will it check? I think removing this bug from blocker list and/or releasing QtWebKit 2.2 without checking what cause random crashes on Mac is absolutely non-sense ...

PS. I'm sure that the Mac bot will be red for the next build.
Comment 9 Ademar Reis 2011-09-09 11:14:05 PDT
(In reply to comment #8)
> (In reply to comment #7)
> > Since we're not sure if this bug indeed affects qtwebkit-2.2, I'm removing it from the blockers list. If we get confirmation, we'll add it back.
> > 
> > BTW, the build passed just now and the 2.2 mac bot is now green.
> 
> And who will it check? I think removing this bug from blocker list and/or releasing QtWebKit 2.2 without checking what cause random crashes on Mac is absolutely non-sense ...

We're about to release a qtwebkit-2.2 RC and this problem (or non-problem) has always been there. If that's indeed a problem, we'll catch it somewhere down the road and add the fix to the release branch. But keeping a bug blocking the release without anyone working on a fix and without even knowing if it's indeed a problem won't benefit anybody. We'll never release 2.2 if we want it to be perfect.

> 
> PS. I'm sure that the Mac bot will be red for the next build.

I'm sure too, and it has been like this for ages. I'm not saying it's a good thing, I'm just saying that I don't know what's causing it and I don't see resources being allocated to fix it.
Comment 10 Csaba Osztrogonác 2011-09-13 00:19:36 PDT
js1_5/Regress/regress-152646.js and js1_5/Regress/regress-192414.js
started to fail again after http://trac.webkit.org/changeset/95016
Comment 11 Csaba Osztrogonác 2011-09-13 00:21:58 PDT
Change the name of the bug, because nobody can confirm if it is a regression or not, because nobody maintains QtWebKit on Mac now. :(
Comment 12 Csaba Osztrogonác 2012-10-08 23:32:21 PDT
Nobody runs layout tests on Qt Mac, nobody knows if it is valid bug or not,
so we can simple close it as wontfix.