Bug 64181 - REGRESSION (r90602): Gmail doesn't load
Summary: REGRESSION (r90602): Gmail doesn't load
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Nobody
URL:
Keywords:
: 64176 (view as bug list)
Depends on: 64279
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-08 11:10 PDT by Ryosuke Niwa
Modified: 2011-07-11 07:05 PDT (History)
10 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2011-07-08 11:10:20 PDT
On ToT WebKit, Gmail no longer loads properly.  Even if it loaded, it doesn't handle clicking and other events properly.
Comment 1 Ryosuke Niwa 2011-07-08 11:13:58 PDT
I can't tell whether this is a regression in loader (XHR?), JSC, or event handling.  The fact page doesn't finish loading seems to suggest some regression in loader but when it loads, I can't interact with the page properly (CSS styles seem to work properly) so I'm also suspecting JSC regression.  However, gmail relies heavily on XHR so it's possible that user interactions are prevented due to some bugs in XHR.
Comment 2 Ryosuke Niwa 2011-07-08 11:24:53 PDT
Okay, this regression still exists in r90643.
Comment 3 Adam Barth 2011-07-08 12:06:24 PDT
Can we get a tighter regression range?
Comment 4 Ryosuke Niwa 2011-07-08 12:11:19 PDT
(In reply to comment #3)
> Can we get a tighter regression range?

I'm building r90594 because I suspect that http://trac.webkit.org/changeset/90595/ is the cause.
Comment 5 Ryosuke Niwa 2011-07-08 12:16:24 PDT
It was not r90595.
Comment 6 Alexey Proskuryakov 2011-07-08 13:10:22 PDT
Testing with our archive builds says that it's r90602 indeed.
Comment 7 Ryosuke Niwa 2011-07-08 13:15:19 PDT
(In reply to comment #6)
> Testing with our archive builds says that it's r90602 indeed.

I have confirmed this on my local build as well.
Comment 8 Ryosuke Niwa 2011-07-08 13:24:13 PDT
+eae since he knows how gmail works.
Comment 9 Gavin Barraclough 2011-07-08 16:39:44 PDT
*** Bug 64176 has been marked as a duplicate of this bug. ***
Comment 10 Gavin Barraclough 2011-07-08 16:41:48 PDT
This should be fixed in r90673 - reverting the changes that look like they are to blame.